-1

My raspberry pi automatically sets disable=1 to all the wifi networks that are not currently connected. So when I take the Pi to other places, it won't connect it to the network automatically even though I have put the SSID and PASS to the conf file in the past.

How can I stop my Pi from disabling the wifi networks in the wpa_supplicant.conf file?

1 Answer 1

2

Don't use the stupid GUI tool (or disable the update-config option).


Every time the GUI changes WiFi networks it disables all others (you would have to ask Raspberry Pi Ltd. WHY).

If disabled it does not. I don't actually use the GUI as I manually enter networks into wpasupplicant and only disable those I don't use e.g. my son's US network.

You can leave enabled if you manually edit your wpasupplicant.

wpa_cli list_networks will show status of devices in wpasupplicant.


NOTE I haven't looked for years (this Q & A is years old and I use Network Manager).

3
  • Sorry, this has been bugging me for a long time. 😀Like, Why does this issue pop up suddenly on a pi that's been working perfectly for a long time. Mar 3 at 13:25
  • Does "disable the update-config option" change other things? Could it cause other problems? Why does it work? Or do I need to accept it as one of life's little mysteries? Mar 3 at 13:31
  • Cheers on the update edit! Just commenting out update config in the WPA_supplicant.conf seems to work so far. I'm only using ssh so no need for GUI. Mar 5 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.