-1

I am caught up in a strange problem that my flashed sd card with Raspian Buster OS works fine with approx 10 of my Raspberry pi-4 but the same is not working on another batch of Raspberry pi 4. I simply get four times blinking of the green led in a pattern indicating that the os is not booting.

So why is this happening? Because my simple guess is if the sd card works in one Rpi4 then it should work in all. Am I missing something? Kindly help.

Edit: If I boot through a newly updated os then all the raspberry pi are working. So no issues with the hardware. The only issue which comes is I am not able to read RFID cards with this. Hence I wanted to stick to my older version of os which is failing to boot in some raspberry pi-4 but working in others.

6
  • so, 10 work, and an unspecified number don't - does anything work on the unspecified number of pi4?
    – Bravo
    Nov 6 at 8:01
  • Is the OS fully updated?
    – CoderMike
    Nov 6 at 8:28
  • @Bravo I edited the question, all the raspberry pi are booting if I do a fresh install of the latest os. So no issues with the hardware. Nov 6 at 8:58
  • @CoderMike even if the OS is not fully updated for example then how are some raspberry pi booting and others are not with the same image? That's where I am confused. Nov 6 at 9:04
  • Later versions of Pi4?
    – CoderMike
    Nov 6 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.