0

I have a freshly installed Raspberry Pi OS on my Raspberry Pi 3 Model B. According to cat /proc/device-tree/model, the OS name is "Raspbian GNU/Linux 10 (buster)". I have installed Stellarium 0.18.3 from the default repositories (sudo apt-get install stellarium). When I start Stellarium, it starts in full screen, and the frame rate is very low — around 1 fps, which is unusable.

I found that I could increase the frame rate by reducing the size of the Stellarium window, so in ~/.stellarium/config.ini, I configured:

  • fullscreen = false
  • screen_h = 480
  • screen_w = 640

With this change, Stellarium runs at around 5 fps, but this frame rate is still too choppy, and the window size is too small to be comfortable. What is the root problem that is causing Stellarium to be so slow? How can I make it run faster?

Perhaps this has something to do with the graphics drivers? When I start Stellarium from the command line, Stellarium prints some information about the graphics drivers. Excerpt:

OpenGL supported version:  "OpenGL ES 3.1 Mesa 19.3.2"
Current Format:  QSurfaceFormat(version 3.1, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize 8, stencilBufferSize 8, samples 0, swapBehavior QSurfaceFormat::SwapBehavior(DefaultSwapBehavior), swapInterval 1, colorSpace QSurfaceFormat::ColorSpace(DefaultColorSpace), profile  QSurfaceFormat::OpenGLContextProfile(NoProfile))
StelMainView::init
Detected: OpenGL ES "3.1"
Driver version string: "OpenGL ES 3.1 Mesa 19.3.2"
GL vendor is "VMware, Inc."
GL renderer is "llvmpipe (LLVM 9.0.1, 128 bits)"
GL Shading Language version is "OpenGL ES GLSL ES 3.10"
MESA Version Number detected:  19.3
Mesa version is fine, we should not see a graphics problem.
GLSL ES Version Number detected:  3.1
2
  • Have you enabled a GL driver in raspi-config, and which one? Nov 8, 2021 at 17:27
  • @DmitryGrigoryev Thank you for the tip. I was able to solve the problem by changing the GL driver.
    – Flux
    Nov 15, 2021 at 11:00

1 Answer 1

0

It turns out that I was using the "Legacy" driver ("Original non-GL desktop driver"), which is the default in my Raspberry Pi OS install.

To solve the low frame rate problem, run raspi-config in the terminal. In raspi-config's menu, select "Advanced Options", followed by "GL Driver", then select "GL (Fake KMS) OpenGL desktop driver with fake KMS" (see screenshots below).

After rebooting, the frame rate in Stellarium is usable. In a 1200x800 window (a comfortable size), Stellarium is able to run at an acceptable frame rate of 5-15 fps on my Raspberry Pi 3 Model B.

raspi-config step 1

raspi-config step 2

raspi-config step 3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.