I've got myself in a spot of bother on my PI4. I set up omxplayer to play a video on repeat at startup not realizing that I wouldn't be able to interact with it - meaning I cannot close it.

I've tried blindly launching terminal in the background with CTRL+ALT+T and typing "killall omxplayer", it didn't work. I also tried "sudo killall omxplayer" but this also did not work.

I also tried plugging the SD card into my macbook and editing the boot text file, but it doesn't look like OSX is able to write to whatever filesystem the card is formatted in.

Unfortunately my PI doesn't have SSH enabled either.

I was hoping that there was a key combo I could press at startup to send me straight to the shell, but from my research it doesn't seem like there is?

  • boot should be fat32 so formatting issue is odd. if all these hotkeys don't work, you could ssh in (mac should be able to make a blank ssh file on boot to enable) and do what needs doing- could even uninstall, delete or move the application so it does not find it on the next reboot.
    – Abel
    Dec 20 '21 at 1:32

Q should be the hotkey for quitting omxplayer.


Ctl+Alt+F4 (or F2-F6) should open a new console login screen.

  • I tried all of those unfortunately.
    – user140577
    Nov 6 '21 at 16:34

killall omxplayer.bin did work for me .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.