-1

I have a raspberry pi 4b 8gb running ubuntu 21.10 desktop that I use. I want ot expand the uses of my pi and I want to run some windows programs. I installed pi-apps, a program helps you install many apps of all kinds; many, including box64 (box64 is an x86 emulator) require wine. I tried to install wine with sudo apt install wine, but at the end of the install it says /usr/bin/dpkg returned an error code (1) and wine does not work. I have not the smallest Idea how to fix it. I only can find builds and installs for a pi 3 running raspberry pi os. I need an answer for a pi 4 running ubuntu.

8
  • Your question is off-topic here, but you might try Software Reccomendations SE. Other than that, this search seems to turn up free x86 emulators - odd that you didn't find it. Finally, remember that, in general, emulation == slow.
    – Seamus
    Nov 6, 2021 at 18:14
  • I've heard that emulation can be not so slow with an overclocked pi like mine. "that search" is one that I've found but I am TERRIBLE at building software from the source; I don't even have the slightest clue on were to start. Also, Ive looked for how to install box86 on a raspi 4b and they only have builds and installs for 3 runing raspberry pi os. I need to know how to do it on UBUNTU!!! Not raspberry pi os. Nov 7, 2021 at 0:05
  • 1
    @random_ubuntu_user Most of the time, Ubuntu (or any other linux variant) are very similar to Raspberry Pi OS. Almost all of the commands are identical and behave the same. So a tutuorial for Raspberry Pi OS should work on Ubuntu almost 1:1.
    – PMF
    Nov 7, 2021 at 7:26
  • 1
    similarly, what works on the pi3 in many cases will work on the pi4
    – Bravo
    Nov 7, 2021 at 7:40
  • I know. I tried to do the tutorial for raspi os on ubuntu it but it did not work; I said, I need to know how to do it on ubuntu specifically. Nov 7, 2021 at 17:08

1 Answer 1

2

Try Pi-Apps: it's a collection of installation scripts for lots of Pi-specific stuff (including Box86 and Wine) with a GUI interface.

It claims to have partial support for Ubuntu, so no guarantees it will work. If you want a smooth experience with a Pi, it's best to use the Pi OS.

6
  • I tried to nistall Pi-Apps but there the terminal window says there was an error and pi-apps does not work. I like ubuntu because it is 64 bit and is WAYY better for gaming than rpi os. I have an imame of raspi os on one sd card and ubntu on another. Sauerbraten is installed on both. The ubuntu sd card runs sauerbraten much faster. Nov 8, 2021 at 0:25
  • @random_ubuntu_user Then you'll just have to actually deal with the errors you get (fix them yourself or report them to the developers and convince them to work on these). Nov 8, 2021 at 0:33
  • It says /usr/bin/dpkg returned an error code (1). That is precise error. I have not the smallest Idea how to fix it. Nov 8, 2021 at 0:38
  • @random_ubuntu_user If this happens directly after opening Pi-apps, you should open an issue on their bugtracker. They claim you "may encounter errors for some apps", but it should work in general. Nov 8, 2021 at 0:47
  • I ran the same pi apps install commands as last time, but magically, it worked! THANKS! Nov 8, 2021 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.