0

I seem to have lost "Wireless & Wired Network" and "Bluetooth" applets for lxpanel after a Buster->Bullseye upgrade. The relevant packages (lxplug-network and lxplug-bluetooth) appears to be installed:

pi@raspberrypi:~ $ dpkg -l | grep lxpanel
ii  lxpanel                                0.10.1-2                         armhf        LXDE panel
ii  lxpanel-data                           0.10.1-2                         all          LXDE panel (data files)
ii  lxplug-bluetooth                       0.21                             armhf        Bluetooth plugin for lxpanel
ii  lxplug-cputemp                         0.6                              armhf        CPU temperature plugin for lxpanel
ii  lxplug-ejecter                         0.15                             armhf        Ejecter plugin for lxpanel
ii  lxplug-magnifier                       0.6                              armhf        Magnifier plugin for lxpanel
ii  lxplug-network                         0.24                             armhf        Network plugin for lxpanel
ii  lxplug-ptbatt                          0.14                             armhf        Battery monitor plugin for lxpanel
ii  lxplug-volumepulse                     0.5                              armhf        PulseAudio controller plugin for lxpanel

However, when I click on "Add / Remove Panel Items" menu, I don't see them in the list.

The relevant services (dhcpcd and bluetooth) are up and running:

pi@raspberrypi:~ $ service bluetooth status
● bluetooth.service - Bluetooth service
     Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
     Active: active (running) since Mon 2021-11-08 22:16:08 CET; 10h ago
       Docs: man:bluetoothd(8)
   Main PID: 584 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 4915)
        CPU: 106ms
     CGroup: /system.slice/bluetooth.service
             └─584 /usr/libexec/bluetooth/bluetoothd

pi@raspberrypi:~ $ service dhcpcd status
● dhcpcd.service - dhcpcd on all interfaces
     Loaded: loaded (/lib/systemd/system/dhcpcd.service; enabled; vendor preset: enabled)
     Active: active (running) since Mon 2021-11-08 22:16:05 CET; 10h ago
    Process: 375 ExecStart=/usr/lib/dhcpcd5/dhcpcd -q -b (code=exited, status=0/SUCCESS)
   Main PID: 425 (dhcpcd)
      Tasks: 2 (limit: 4915)
        CPU: 16.272s
     CGroup: /system.slice/dhcpcd.service
             ├─425 /sbin/dhcpcd -q -b
             └─588 wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dnl80211,wext

pi@raspberrypi:~ $ iwconfig wlan0
wlan0     IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=31 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on

pi@raspberrypi:~ $ bluetoothctl scan on
Discovery started
[CHG] Controller AA:AA:AA:AA:AA:AA Discovering: yes
[NEW] Device 51:81:EA:67:17:47 51-81-EA-67-17-47
[CHG] Device 51:81:EA:67:17:47 RSSI: -45
[CHG] Device 51:81:EA:67:17:47 RSSI: -62

Did I install the wrong packages, or is there a configuration for lxpanel that I need to apply?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.