0

Context:

I have 8 Raspberry Pi Computers in my class. After flashing the most recent version of Raspbian onto 8GB SD cards which were originally sold with NOOBS on them (the cards are therefore Raspberry Pi ready), we were able to login to the desktop and connect to WiFi through the school WiFi network. We are able to browse on the web and also ping a range of websites through the terminal.

Problem:

On 7 of the machines when we ran

sudo apt-get update

We received:

Hit http://raspberrypi.collabora.com wheezy Release.gpg
Hit http://raspberrypi.collabora.com wheezy Release                            
Hit http://mirrordirector.raspbian.org wheezy Release.gpg                      
Hit http://archive.raspberrypi.org wheezy Release.gpg                          
Hit http://mirrordirector.raspbian.org wheezy Release                          
Hit http://archive.raspberrypi.org wheezy Release
Get:1 http://raspberrypi.collabora.com wheezy/rpi armhf Packages      
Get:2 http://mirrordirector.raspbian.org wheezy/main armhf Packages            
Get:3 http://raspberrypi.collabora.com wheezy/rpi Translation-en_GB            
Get:4 http://raspberrypi.collabora.com wheezy/rpi Translation-en               
Hit http://repository.wolfram.com stable Release.gpg                  
Hit http://mirrordirector.raspbian.org wheezy/contrib armhf Packages           
Hit http://mirrordirector.raspbian.org wheezy/non-free armhf Packages          
Hit http://mirrordirector.raspbian.org wheezy/rpi armhf Packages
Get:5 http://archive.raspberrypi.org wheezy/main armhf Packages
Get:6 http://mirrordirector.raspbian.org wheezy/contrib Translation-en_GB
Get:7 http://archive.raspberrypi.org wheezy/main Translation-en_GB            
Get:8 http://mirrordirector.raspbian.org wheezy/contrib Translation-en         
Get:9 http://archive.raspberrypi.org wheezy/main Translation-en                
Get:10 http://mirrordirector.raspbian.org wheezy/main Translation-en_GB        
Get:11 http://mirrordirector.raspbian.org wheezy/main Translation-en           
Get:12 http://mirrordirector.raspbian.org wheezy/non-free Translation-en_GB    
Hit http://repository.wolfram.com stable Release                               
Get:13 http://mirrordirector.raspbian.org wheezy/non-free Translation-en       
Get:14 http://mirrordirector.raspbian.org wheezy/rpi Translation-en_GB         
Get:15 http://mirrordirector.raspbian.org wheezy/rpi Translation-en            
Hit http://repository.wolfram.com stable/non-free armhf Packages               
Get:16 http://repository.wolfram.com stable/non-free Translation-en_GB
Get:17 http://repository.wolfram.com stable/non-free Translation-en
Fetched 65.2 kB in 13s (4,992 B/s)                                             
W: Failed to fetch gzip:/var/lib/apt/lists/partial/raspberrypi.collabora.com_dists_wheezy_rpi_binary-armhf_Packages  Hash Sum mismatch

W: Failed to fetch gzip:/var/lib/apt/lists/partial/mirrordirector.raspbian.org_raspbian_dists_wheezy_main_binary-armhf_Packages  Hash Sum mismatch

W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.raspberrypi.org_debian_dists_wheezy_main_binary-armhf_Packages  Hash Sum mismatch

E: Some index files failed to download. They have been ignored, or old ones used instead.

We can ping archive.raspberrypi.org etc without any problems.

On one of the machines sudo apt-get update worked and the pupil was able to install scrot but then we removed scrot and then attempted a reinstall of scrot we received the exact same errors as above.

I have attempted all the suggestions from a similar error I had before posted here on stack exchange including reflashing the SD card again.

Assistance very much appreciated.

3

I had a similar problem with the update, i.e. a Hash Sum Mismatch in the binary-armhf_Packages.
I fixed it by trying different mirrors in the /etc/apt/sources.list.

I'm using the insideelectronics one and only that.

http://www.raspbian.org/RaspbianMirrors

1
  • I had to add an extra /raspbian to the mirror – Charlie Aug 14 '16 at 6:02
0

This same problem often happens to me when my Raspberry Pi's system time is too far off from the actual UTC time, as it usually is when I first try to do a sudo apt-get update. This is because the Raspberry Pi doesn't have a hardware clock and needs needs to use ntp to sync up.

Try running the date command on your Raspberry Pi to see if its system time is more than a few minutes off from UTC time (which can be found here).

If it is, you can run this command to sync back up:

sudo sntp -s time.google.com

You may also need to run

sudo rm -rf /var/lib/apt/lists/partial

before tyring

sudo apt-get update

again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.