0

I want to be able to connect through different phones' hotspots (Pi4 - operating system of last June - the Pi has a static IP).

I am only able to connect to the latest phone that was connected and wpa_supplicant shows the others as disabled=1

I followed this post: How to setup multiple WiFi networks?

But every time I modify wpa_supplicant the file goes back to its original script. Basically:

  1. I delete disabled=1,
  2. I add the priority
  3. and I add names for the id_str
  4. then I press CTRL+X and Y

However nothing changes and I am only able to connect to the latest phone's hotspot the pi was connected.

If I re-open wpa_supplicant.conf just after I supposedly change it the file it is in its original format including the disabled=1, no priorities and id_str.

What am I doing wrong?

2
  • Have you tested whether your SDCard has failed info "read only" mode.
    – Dougie
    Nov 12, 2021 at 14:25
  • Thank you for the suggestion! The SD card was ok. I solved the issue following the PI official documentation linked bellow. I do not know why the networks not used last were disabled but I had the same issue with several PIs and I had to manually reconfigure them.
    – have fun
    Nov 14, 2021 at 8:14

1 Answer 1

0

"What am I doing wrong?"

Using the Network icon on the Desktop to change WiFi networks.

This is how it is DESIGNED to work, and is the only (reliable) way of MANUALLY switching networks.

You could set update_config=0 - but then you can't use the Network icon to change WiFi networks.

There should be no need to MANUALLY switch networks on a correctly configured wpa_supplicant.conf.

See How to set up networking/WiFi

PS setting static IP is a recipe for disaster with different hotspots. It MAY work if they ALL use the most common setting.

Incidentally that post is hopelessly out of date. Following any 8 year old tutorial is dangerous.

1
  • Thank you. I followed the PI documentation linked in your post and managed to delete the "disable=1" I do not know why it was there in first place. I think that the old post should be perhaps closed? Or at least a link on your tutorial provided?
    – have fun
    Nov 12, 2021 at 8:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.