0

I've been trying to follow tutorials on enabling hardware accelerated video decoding for my Raspberry Pi 3b+, such as this one:

https://lemariva.com/blog/2020/08/raspberry-pi-4-video-acceleration-decode-chromium

They all seem to want me to select a GL Driver called "Fake KMS", but even after installing the various packages mentioned, it's not listed for me.

I'm using the latest version of Raspberry Pi OS, with updates installed.

  • cat /proc/device-tree/soc/firmwarekms@7e600000/status returns disabled
  • cat /proc/device-tree/soc/v3d@7ec00000/status returns okay
  • chrome://gpu shows Video Decode: Software only: Hardware acceleration disbled

How can I make this option avaiable, or otherwise do what is needed to enable GPU video decoding in chromium?

Image of raspi-config with Fake KMS missing as an option

5
  • I assume that link points to instructions for older release of Pi OS - if you have the latest (bullseye) release - then you should have dtoverlay=vc4-kms-v3d in your config.txt
    – Bravo
    Commented Nov 14, 2021 at 8:54
  • @Bravo I did this and restarted, and it doesn't seem to have affected anything. Commented Nov 14, 2021 at 10:25
  • So, which version of Raspberry Pi OS do you have installed?
    – Bravo
    Commented Nov 14, 2021 at 11:35
  • @Bravo 11 (bullseye) Commented Nov 14, 2021 at 12:10
  • oh, and you're reading a video acceleration page for pi4 but you don't have a pi4
    – Bravo
    Commented Nov 15, 2021 at 1:27

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.