0

Having an issue I've not really had before. The Pi(4) doesn't hang (remains connected via ssh) but looks like the filesystem gets corrupted (get input/output errors for any command). If I pull the sd card and check partitions on my dev box they're fine. Then if I reboot it's fine for some time. For example all fine then let it run all night and in the am the issue.

Using RPi 4 and 4 64gb sd cards (tried 3) all same brand and lot (silicon power 1 @10, XC-I which should be fine). I loaded on an ubuntu arm64 focal image

Using a 3amp generic ps with good quality usb C cable. I've tried in the the two RPi4 I have and same issue.

There is no reporting from the kernel of low power at boot (far as I know)

So any thoughts on the likely culprit. Like bad sd cards?, some issue with focal? some ps issue? To me it seems a ps issue the way the card doesn't get corrputed. I've tried two PS now. Guess I'll try a totally different SD card. I've read that if the screening on the card is pixelated it may be fake. These look pixelated

Given the card doesn't report corruption after the issue starts I'm kinda at a loss to track this down.

I've used the same image (different sd card) on an rpi3 without issue. In fact years of running RPi's from ver 1 and never this issue no matter the sd card.

I should mention that I created a second ext4 partition and mounted it in fstab and use it for additional non os files and apps and containers. That shouldn't be an issue

1 Answer 1

0

I set up a different brand and spec 16 GB card (one that I've used successfully). It's now been 24 hours with no issue. So looks like it was that particular brand/spec of SD card causing the issue. That's the first time I've bought silicon power SD cards looks like the last.

So conclusion. Be careful which SD card you purchase. Use samsung or sandisk, try to confirm that the seller is legit and chose one from a recent SD card recommendation for the Raspberry Pi. I just ordered two of these which were recommended. I did not opt for a A2 spec card as one careful evaluation saw no benefit.

https://www.amazon.com/gp/product/B07B98GXQT/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1

https://www.pcguide.com/raspberry-pi/guide/best-sd-card/

https://www.jeffgeerling.com/blog/2019/a2-class-microsd-cards-offer-no-better-performance-raspberry-pi

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.