1

I am turning my RPi into a Plex server. I have connected the drive using a powered USB hub, and the output from sudo fdisk -l returns with this on the end:

Disk /dev/sda: 931.5 GiB, 1000204884992 bytes, 1953525166 sectors
Disk model: Storage Device
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xa9f8da84

Device     Boot Start        End    Sectors   Size Id Type
/dev/sda1        2048 1953519615 1953517568 931.5G  7 HPFS/NTFS/exFAT

This is the correct drive. I then ran sudo mkdir -p /media/Plex and sudo chown -R pi:pi /media/Plex To get the drive information, I ran sudo blkid /dev/sda1 which returned

/dev/sda1: LABEL="Plex Drive v1" UUID="6A3C98473C980FE5" TYPE="ntfs" PARTUUID="a9f8da84-01"

(I have ntfs-3g installed)

Finally, I added the line UUID=6A3C98473C980FE5 /media/Plex ntfs defaults,auto,users,rw,nofail,noatime 0 0 to the fstab file

When I run sudo mount -a

The console returns

ntfs_mst_post_read_fixup_warn: magic: 0x43425355  size: 4096   usa_ofs: 42208  usa_count: 62766: Invalid argument
Corrupt index block signature: vcn 0 inode 5
Failed to open $Secure: No such file or directory
Failed to mount '/dev/sda1': No such file or directory

I have no idea why this is happening, but any help would be appreciated, Thanks in advance, Gabi

7
  • what happens if you try PARTUUID=a9f8da84-01 ... etc instead? - I doubt it'll make a difference, but just wondering - also, can you manually mount it? i.e. sudo mount /dev/sda1 /media/Plex successfully? I take it the partition is correctly formatted as NTFS? (why are you using NTFS though)
    – Bravo
    Nov 15, 2021 at 23:50
  • Using the Partition UUID doesn't work either Nov 15, 2021 at 23:57
  • Manually mounting results in the same error as automatically mounting Nov 15, 2021 at 23:58
  • I am using NTFS because I transferred all my media on to the drive before realising that it was NTFS, and it takes hours to move the media back and forth, so I'm trying to avoid doing that Nov 15, 2021 at 23:59
  • How do you mean correctly formatted? Is there a way to tell? Nov 16, 2021 at 0:00

1 Answer 1

0

This may not be the solution to your particular problem but similar errors to what you see were given in this thread on linuxquestions. It's probably a good procedure to follow if you're getting nowhere. Essentially try;

Boot your windows system and run chkdsk, read up on the parameters. If you don't have windows installed, boot your windows install media and run chkdsk. Borrow a windows CD/DVD and run chkdsk.

Since it's a USB disk it should be easy to reconnect to a Windows box to use CHKDSK.

It was also suggested to run sudo ntfsfix /dev/sda (first). The man page says it can fix some common NTFS problems but maybe more usefully schedule an NTFS consistency check for the first boot into Windows.

For reference I have a 1TB USB drive with media stuff on it that is ntfs formatted and is now connected to my Pi4. Very similar to you. My fstab has;

/dev/sda1      /media/nas      ntfs-3g    auto,rw,noatime     0       0

and I've never had any problems mounting the drive.
Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.