0

I have a fresh raspbian image on a class-10 32gb SDHC card in my Raspberry Pi Model B, created according to instructions on the raspberry pi website. My actual internet download speed is >10 mbytes/s.

The pi was booted up for the first time, and I ran sudo apt-get dist-upgrade in lxterminal. It has since been running for over two hours. There was no dialogue, no words, just an endless scrolling of "pi@raspberrypi ~ $" in lxterminal.

When I tried to open a second lxterminal to run Top to see what was happening, hundreds of blank lxterminals opened, which I then had to force close by answering accordingly to a prompt to send it a terminate signal. Eventually all the lxterminal windows vanished. However, the SD card I/O is still constantly lit and the keyboard and mouse have stopped responding.

Is this normal behaviour? How long should apt-get dist-upgrade take under normal circumstances? Should the plug be pulled?

  • That is most definitely erratic behaviour for a Pi. I would pull the plug and try booting it up again. What are you using to connect to the internet (Ethernet/WiFi?) and if WiFi, what's the model. Also, are any external USB hubs connected? One last thing, Class 10 SD cards, especially larger ones, can have issues, especially earlier versions of the Pi. What brand/version is yours? – RPiAwesomeness Jan 30 '14 at 22:37
1

most probably (constantly scrolling "pi@raspberrypi ~ $" and hundreds of open windows) you just have an "enter" key stuck on your keyboard, or there's something else funny with your keyboard. please, try to get another keyboard and see if the same thing happens again.

regarding the original question about dist-upgrade, this should not take more than a few (maybe 10) minutes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.