2

This is on a system upgraded from Buster to Bullseye. Ethernet works fine, but WiFi cannot scan for available networks with "No carrier" error message:

pi@raspberrypi:~ $ connmanctl enable wifi
Error wifi: Already enabled
pi@raspberrypi:~ $ connmanctl scan wifi
Error /net/connman/technology/wifi: No carrier

I can see that wlan0 is there, not blocked by rfkill and wpa_supplicant is running.

pi@raspberrypi:~ $ iwconfig
lo        no wireless extensions.
eth0      no wireless extensions.
wlan0     IEEE 802.11  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=31 dBm
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
pi@raspberrypi:~ $ rfkill list
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: hci0: Bluetooth
        Soft blocked: yes
        Hard blocked: no
pi@raspberrypi:~ $ systemctl status 579
● dhcpcd.service - dhcpcd on all interfaces
     Loaded: loaded (/lib/systemd/system/dhcpcd.service; enabled; vendor preset: enabled)
     Active: active (running) since Fri 2021-11-19 16:40:15 CET; 24h ago
    Process: 429 ExecStart=/usr/lib/dhcpcd5/dhcpcd -q -b (code=exited, status=0/SUCCESS)
   Main PID: 489 (dhcpcd)
      Tasks: 2 (limit: 4915)
        CPU: 34.626s
     CGroup: /system.slice/dhcpcd.service
             ├─489 /sbin/dhcpcd -q -b
             └─579 wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dnl80211,wext

Is there anything else I should check? Or is connmanctl not supposed to work on Bullseye?

@Milliways, connman appears to be installed as a dependency of lxde, which is what I have for desktop on the Pi:

pi@raspberrypi:~ $ apt-cache --installed rdepends connman-gtk
connman-gtk
Reverse Depends:
 |lxde
10
  • 1
    Did you install connman yourself? I have never used it, but the instructions say to disable other networking systems. You have the normal Raspberry Pi OS dhcpcd client running.
    – Milliways
    Nov 20 '21 at 21:56
  • Did you see this Q&A in the Arch forum?
    – Seamus
    Nov 21 '21 at 3:41
  • @Milliways I didn't install it myself. Looking at this answer made me think this is now the default GUI network manager in Raspbian. Is that not the case? Nov 21 '21 at 11:00
  • @Seamus I sure did. The pi user is not in wheel and network groups, but I assumed it's arch-spesific Nov 21 '21 at 11:01
  • 1
    The pi user is not in wheel and network groups... Yeah, those groups don't exist in Debian, but they have equivalents: wheel ~ sudo, network ~ netdev. I wondered if group memberships were changed during the upgrade? Anyway - from the discussion here, your other question, and this question this seems rather a significant issue!
    – Seamus
    Nov 21 '21 at 21:10
1

I would just delete connman - from similar posts the dhcpcd plugin (I would have to search to find its name) appears to be installed.

Its normal operation depends on the dhcpcd service (which appears to be running) but dhcpcd disables itself and its wpa supplicant plug-in if another DHCP client is active.

I will investigate later if this doesn't resolve your issue.

I would use CLI to see what IP have been allocated.


See https://www.raspberrypi.com/news/another-raspbian-desktop-user-interface-update/

I think you want the dhcpcd-ui package

apt search dhcpcd-ui
lxplug-network/stable,now 0.29 armhf [installed,automatic]
  Network plugin for lxpanel
1
  • Thanks, I removed connman since it apparently got installed by mistake during the dist-upgrade. I'm still looking for a GUI to manage the network connections, but now I know it's not going to be connman. Nov 21 '21 at 21:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.