0

I'm trying (and failing repeatedly) to connect to a Pi Zero W using SSH over a USB connection. I know this question has been asked before, but trying the solutions brought up in those threads has unfortunately been unsuccessful, so I'm asking again in the hope I may be missing something that's changed since they've been asked.

The computers I want to interface with the Pi are a Lenovo Yoga C930 2019 running Windows 10 20H2, and a Dell all-in-one computer from my college running Windows 10 21H1

I've been following the tutorial in the following link: https://www.tomshardware.com/reviews/raspberry-pi-headless-setup-how-to,6028.html

I've:

  • Installed the full Pi OS (32-bit, 30-10-2021 release) version on (two separate) Kingston Canvas Select Plus 32GB microSD card, as well as a SanDisk Edge 32GB microSD card using Raspberry Pi Imager;
  • Added the "ssh" extensionless file to /boot
  • Added "dtoverlay=dwc2" to the bottom of /boot/config.txt
  • Added "modules-load=dwc2,g_ether" after "rootwait" in cmdline.txt, with one space between "rootwait" and the addendum and one more between the addendum and the next term ("quiet")*
  • Installed Bonjour Print Services V2.0.2 for Windows (on both computers)
  • Installed PuTTY on both computers
  • Inserted the SD card into the Pi Zero W
  • Attached a USB to micro-USB cable from the computers' USB ports to the port on the pi labeled "USB" (not PWR_IN)
  • Waited 90+ seconds for the Pi to boot up
  • Attempted to SSH into the pi using PuTTY (hostname raspberrypi.local, Port 22, SSH)

Each time, I get a time out and an error message saying "Unable to open connection to raspberrypi.local. Host does not exist." I also cannot ping raspberrypi.local with any success, and get "Ping request could not find host raspberrypi.local. Please check the name and try again."

I've tried (once) to forgo the file modification by using Pi Imager's secret menu to enable SSH and set up wifi connection, and have (on multiple other occasions) set up a wpa-supplicant.conf** to connect via wireless SSH with the same results. I know that the piOS installations work, since plugging the pi into a monitor with an HDMI cable and attaching mouse/keyboard via a USB hub is perfectly functional, but I'm getting tired of plugging in half a dozen cables to the thing every time I want to use it.

I did note that when setting up the wireless SSH, failing, and then connecting to it directly, the pi apparently failed to connect to wifi automatically (though I could then connect to it manually just fine).

I have noted that as of my most recent attempts to install and enable SSH, my computer apparently doesn't see my Pi as a RNDIS gadget in device manager, rather as a serial COM device on COM12, though I was getting the RNDIS popup previously.

I would really appreciate some input from someone with more experience, because I'm very new to using a Pi and have no idea what I'm doing wrong, if anything, and I just want to be able to interface with it without too much hassle.

*I noticed that in config.txt, the tutorial above shows the file ending after the line "dtparam=audio-on", whereas mine had much more inside of it. I tried inserting the dtoverlay line at the bottom of mine as well as below dtparam=audio-on on separate occasions, but it made no difference.

**containing the following:

country=CA
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
scan_ssid=1
ssid="your_wifi_ssid"
psk="your_wifi_password"
}

update: Since trying to connect to the Pi using SSH-over-USB, it appears that I've managed to destroy the USB port on my Pi. I was previously connecting a keyboard and mouse to it using a USB hub connected to the USB port, and while this hub still receives power the keyboard and mouse no longer interface with the Pi at all. Is it possible to burn out the USB ports (on two boards, no less) just by connecting the USB port to a computer via a USBA-to-micro-USB cable?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.