2

I am using Raspberry Pi OS Bullseye. The VLC was preinstalled on the OS. When I tried playing videos, the quality turned out to be poor. I checked by launching VLC from the terminal, but it gives out this error:

VLC media player 3.0.16 Vetinari (revision 1.0.6-1682-g88158c836)
[00c5eb98] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[94872198] mmal_codec decoder: VCSM init succeeded: CMA
mmal: mmal_component_create_core: could not find component 'vc.ril.video_decode'
[94872198] mmal_codec decoder error: Failed to create MMAL component vc.ril.video_decode (status=4 ENOSYS)
[a2706dc0] gles2 gl: Initialized libplacebo v2.72.0 (API v72)
[a2704c60] mmal_xsplitter vout display error: Failed to open Xsplitter:mmal_vout module

Also, there is this line:

[8c954138] gles2 gl: Initialized libplacebo v2.72.0 (API v72)

What I don't get is if it was working fine in Raspberry Pi 3, as claimed here: https://forums.raspberrypi.com/viewtopic.php?f=66&t=195221, why its not working fine for Raspberry Pi 4? Or, can I be doing something wrong here?

1 Answer 1

0

The Raspberry pi 4 is not the same thing as the Raspberry pi 3. Chances are that the version of VLC that you posted as a link doesn't work on the Raspberry Pi. Bullseye is also a relatively new OS, it is possible that it is still buggy. Have you tried running VLC on Raspbian Buster? It works on my Raspberry pi 4 just fine. If you don't want to install Buster, have you tried deleting all VLC packages and reinstalling them again? Run sudo apt purge vlc libvlc-bin libvlc5 libvlccore8 vlc-bin vlc-data vlc-l10n vlc-plugin-base vlc-plugin-notify vlc-plugin-qt vlc-plugin-samba vlc-plugin-skins2 vlc-plugin-video-output vlc-plugin-video-splitter vlc-plugin-visualization to completely delete all vlc packages. Then run sudo apt install vlc to install them again. I hope this helped!

3
  • So, I am using stock Raspberry Pi OS, installed on SD card by choosing the recommended version, which installed Bullseye. I also tried removing VLC from my system and reinstalling it, but same error of mmal component missing. Also tried to follow thread on compiling VLC, but looks like the required dependencies are not there in Bullseye repo. I don't know how its working for you. Nov 27, 2021 at 8:27
  • Do you need Raspberry Pi OS Bullseye? If VLC is a necessity for you why not revert to Buster? downloads.raspberrypi.org/raspbian/images/raspbian-2020-02-14/… is where you can find Raspbian Buster. Nov 27, 2021 at 12:44
  • Yeah, I will try using buster. Although, when I read about it, the MMAL, which is needed by VLC, is now deprecated on Raspi 4. Also, there are some hardware changes I think. Now, decoders may have to use v4l2, I guess. Not sure whether buster can utilise new GPU properly, with VLC using OpenMAX, but its worth a try. Nov 27, 2021 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.