I recently updated my RPi-3B to bullseye. Since then I am not able to connect it to my wifi. It shows the following message when I login

Wi-Fi is currently blocked by rfkill.
Use raspi-config to set the country before use.

My wpa_supplicant file is definitely correct as of now.

$ cat /etc/wpa_supplicant/wpa_supplicant.conf 
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

If I run rfkill list following is what I get

$ rfkill list
0: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: no

I have run sudo raspi-config nonint do_wifi_country IN but even after this I get the same issue.

The only solution that works for me is to login to console and then enter the rfkill unblock all

I wonder which is the secret config which is enabling rfkill to block wifi

  • 1
    A number of others who tried an unsupported upgrade have had similar problems. It seems to be related to the installation of connman. The solution is to do a fresh install as suggested by RPT.
    – Milliways
    Nov 27, 2021 at 9:40
  • 1
    I note you have removed connman, but there are other issues which may cause problems. Frankly Bullseye is not yet ready for general use even if you do a fresh install.
    – Milliways
    Nov 27, 2021 at 22:21
  • That statement is pretty damning.
    – the100rabh
    Nov 28, 2021 at 7:50
  • See raspberrypi.com/news/raspberry-pi-os-debian-bullseye - and form your own opinion.
    – Milliways
    Nov 28, 2021 at 9:58

6 Answers 6


Answer https://raspberrypi.stackexchange.com/a/135176/143506 by Matthew Brett works, however, the sudo unblock wifi command is missing rfkill, should look like this:

sudo rfkill unblock wifi

I ran into this when doing a apt dist-upgrade to Debian Bullseye from Debian Buster.

Despite everything, rfkill list recorded my Wifi as being soft-blocked.

The eventual solution was:

sudo apt install urfkill
sudo rfkill unblock wifi

At last, Wifi came up correctly after reboot.


  • Did you mean sudo rfkill unblock wifi? There is no unblock command that I can find. Jun 24, 2022 at 23:40

Just need to log in (I used the console) and configure connman. connmanctl etc etc. Give it your wifi password and you should be good to go. wpa_supplicant is not needed

  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Sep 19, 2022 at 16:42

I had a similar problem, no Wi-Fi after upgrade to Bullseye, or rather no automatic WIFI at boot time. Turns out that connman is the culprit.

After I did sudo apt purge connman the Wi-Fi turned on immediately after boot as expected.

  • This did it for me, thanks! I had already done sudo rf kill unblock wifi which worked when I ran it, but I still wasn't getting wifi at startup. Uninstalling connman as you suggested fixed that
    – Foxichu
    Jan 3, 2023 at 20:34

What helped for me (after above tips failed) was to re-enable booting up the Desktop GUI (raspi-config option S5). After rebooting once, WLAN came up fine. I once logged into the desktop to check everything, then used rapsi-config again to set it back to text console and after next reboot WLAN still worked.


sudo systemctl disable connman

did it for me, probably wifi isn't configured in connman, so rfkill is triggered, if you need it, you have to configure it and may be also works than.

systemctl status connman - no connman in buster - new in bullseye. That's why there is no config after updating while a fresh bullseye probably has a connman config.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.