-1

I tried to install Ubuntu Server using the official Imager (so without downloading the image myself)

enter image description here

Ubuntu starts to boot, I see some command line output. Too fast to read it all, I see e.g. messages that the processor is not supported, then it looks like normal boot messages from a linux OS starting the default services. But after this, the screen is just turned off and went to standby, so it doesn't get a signal any more.

I tried different options in the usercfg.txt, inspirated by other questions like this one

# Place "config.txt" changes (dtparam, dtoverlay, disable_overscan, etc.) in
# this file. Please refer to the README file for a description of the various
# configuration files on the boot partition.
#hdmi_safe=1
hdmi_force_hotplug=1
config_hdmi_boost=4
hdmi_drive=2

This file didn't contain any settings. I also tried to just set hdmi_safe=1 (uncommented). The only noticeable change is that I get a colored (like rainbow) screen on the start, without any console messages. A few seconds later, it shows the same behavior (screen turns off).

Why doesn't this work? Since I installed Ubuntu Server, I'd expect to get a console login on my screen after the boot.

4 Answers 4

0

Why are you changing usercfg.txt instead of /boot/config.txt? According to this link, adding hdmi_force_hotplug=1 and hdmi_drive=2 to /boot/config.txt helps to solve a problem similar to yours. I think you are just editing the wrong file! If that doesn't work, add the hdmi_boost setting you used in your question to the file. If that really doesn't work, try to set config_hdmi_boost=4 to config_hdmi_boost=6. (I don't know if this is safe or not but someone else on Stack Exchange tried it and it worked for them...) If nothing works, I will recommend that you do what everyone should do if they encounter such a problem - reflash you SD card. I hope this helped!

4
  • Because the /boot/config.txt contains a comment: Please DO NOT modify this file; if you need to modify the boot config, the "usercfg.txt" file is the place to include user changes. The user.cfg is also included at the end of config.txt, so I thought it should be the right way to modify user.cfg. To be sure, I tried to add those directives directly to config.txt, but with the same result. I also switched HDMI ports, without changes.
    – Lion
    Commented Nov 27, 2021 at 13:31
  • I also switched HDMI ports, without change. According to the documentation, the config_hdmi_boost directive seems to be ignored on the RPI4. The card was re-flashed multipe times, on Linux as well as on Windows. I tried Ubuntu Server 21.10 with the same result. I'll try to film the messages since the green LED no longer blinks after the screen went off, like the pi had been shut down.
    – Lion
    Commented Nov 27, 2021 at 13:33
  • Have you tried adding the setting hdmi_ignore_edid=0xa5000080 to your config.txt? That could also work. Commented Nov 27, 2021 at 13:42
  • By filming the boot I found out that HDMI is not the problem, it's caused by the RPI Imager... I have added a more detailed answer. But thank you for your help anyway :)
    – Lion
    Commented Nov 27, 2021 at 14:04
0

The HDMI settings didn't help. I saw errors during the boot, but the screen went off too fast to read them. So I filmed the screen and extracted the last picture before the monitor switched off to see what's going on. It turns out that because of the error I saw, the pi just shut down:

Boot screen

This ticket indicates that the problem is caused by the advanced options in the Raspberry Pi imager, which can be opened using [CTRL] + [Shift] + [X]. I used this feature a lot with Raspberry Pi OS because it's very handy, but it seems to be not working correctly with Ubuntu. By disabling all pre-configuring settings in the advanced options (= unchecking all checkboxes, e.g. for enabling SSH) the kernel error went away. I'll have a look at CloudInit, afaik it should be possible to apply any pre-configuration settings from the imager with CloudInit too, so we don't need a screen and keyboard to setup a RPI based Ubuntu Server.

Since the ticket was posted in the wrong repo, I had a look in the rpi-imager repo and found issue #213, so the problem is known there too. Since several other people spend time to finding this out, I'd welcome at least a warning message in the advanced options as already suggested in the tickets, that those will only work on Raspberry Pi OS and can even break other distributions.

Until we have some workaround like this, my answer to this question which shows the symtoms may help. The biggest problem was, that it looked like a HDMI/screen issue at the first time, since it was not easily possible to read the error message. With the error message, it's easy to find those tickets pointing out that this problem is caused by the advanced customization options in RPI imager.

0

NOTE rather than posting an "answer" you should edit your Question with ALL information.

If you have used the imager advanced option it will corrupt your SD Card.

It assumes dhcpcd networking (which Ubuntu definitely doesn't use; it uses systemd-networkd) and relies on other Raspberry Pi OS features.

In particular it does not use the same boot method.

As you have discovered the RPT "Documentation" leaves a lot to be desired. They assume everyone is using the latest Pi4 and Raspberry Pi OS.

I have discovered that once using the "advanced" option it is difficult to stop. It continues to try, even on inappropriate images. It has corrupted my backup restoration.

0

for the RPi4B Ubuntu server install (or desktop install) the correct config.txt file to edit is located in the /boot/firmware directory.

1
  • 2
    Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Mar 1, 2022 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.