0

I have a Raspberry Pi 4, and have been having trouble connecting to it with VNC Viewer. I have connected to it before, but recently I restarted my Windows 10 computer (without installing any major updates or anything) and since then it hasn't worked. When I type the IP that I have used to connect to my Pi in the past into VNC, an error comes up saying "No route to the host is known". The Pi doesn't show up when I type ipconfig into the command prompt, and when I try nslookup raspberrypi, it says the server can't find raspberrypi: Non-existent domain. I'm confused about this as my Pi is connected to my laptop via Ethernet and I'm not doing anything differently from what I was doing before.

Thanks in advance for any help.

1
  • Nothing to do with Pi. This is a network or Windows problem.
    – Milliways
    Nov 27, 2021 at 21:36

2 Answers 2

0

Your Windows cannot find the IP address of the "raspberrypi" domain. You mention that you cannot connect to the IP address that you used to connect to - did you check that the raspberrypi's IP is still the same? Chances are your Windows changed RPi's IP after the reboot.

0

The IP adresses of devices on your network can change from time to time. Check them incase the IP was just changed and you are trying to connect to the wrong IP.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.