0

I've a PI4 8gb model with a fresh install of Bullseye 64bit and Im getting really poor VNC performance over 2.4ghz wifi network, both devices the client (a mac book pro i9 w/64gb ram) and the server (the pi) are very close to the router, my router is a TP-Link AX1800, there is no other network traffic to be concerned about that would impact the router performance. The ping time is roughly 10ms max. I've also tried X11 forwarding and it too suffers from bad performance, im using xQuartz on my mac.

iwconfig wlan0:

wlan0     IEEE 802.11  ESSID:"TP-Link_42B4"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: C0:C9:E3:4B:42:B3   
          Bit Rate=72.2 Mb/s   Tx-Power=31 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=70/70  Signal level=-26 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
3
  • what's the output of iwconfig wlan0
    – Bravo
    Nov 28 '21 at 5:02
  • wlan0 IEEE 802.11 ESSID:"TP-Link_42B4" Mode:Managed Frequency:2.437 GHz Access Point: C0:C9:E3:4B:42:B3 Bit Rate=72.2 Mb/s Tx-Power=31 dBm Retry short limit:7 RTS thr:off Fragment thr:off Power Management:on Link Quality=70/70 Signal level=-26 dBm Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:0 Missed beacon:0
    – bmaggi
    Dec 1 '21 at 20:48
  • I am having the same issue, except I am on a wired connection to the Pi (I use it as a media server and administer it via various bots, cron jobs and VNC
    – Takuhii
    Dec 5 '21 at 21:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.