1

I have an old model B I'm trying to connect to a 7" touchscreen.

I put a brand new raspian lite image on an SD card, then followed this guide to get everything working (almost).

It starts by showing the kernel image, then it displays the startup log to the screen fine, but during this (pretty consistently just after mounting the boot drive) the screen fades to white and then black, but is clearly still powered. While it's fading the startup log freezes.

  • I've tried several different power supplies, and even powering the screen and pi separately.
  • I've tried reseating the FPC connection.
  • I don't really know what I2C is but I unplugged everything but the touchscreen and the SD card from the pi.

No changes.

Any ideas what this could be? A bad FPC cable? Have all the power supplies I've tried just not been good enough? Thanks in advance.

1
  • maybe the video signal ceases to be generated
    – jsotola
    Nov 29, 2021 at 5:18

1 Answer 1

1

Same problem. Worked on Jessie earlier today but won't boot to desktop with Bullseye. Display driver change?

EDIT: Issues is under investigation https://github.com/raspberrypi/linux/issues/4686

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.