0

I'm currently facing an issue where my Raspberry Pi camera is not detected. However, I did manage to use the camera once before it stopped being detected. There was always a tiny light at the corner of the camera that is always on. After ending the python program which used the camera, the light went off and I could not seem to get it to work again.

When I ran vcgencmd get_camera in the command terminal, the output was supported=1 detected=0.

I tried running my python code again but the error shows

picamera.exc.PiCameraError: Camera is not enabled. Try running 'sudo raspi-config' and ensure that the camera has been enabled.

Upon seeing that it was not "Enabled", I went to check my configurations and it was already enabled. So I just disabled it and then enabled it again just to be safe. Then, same error came up.

Right now I'm really lost as I've tried everything I found online.

  1. Enabling I2C
  2. Reconnecting the hardware
  3. Changing camera
  4. Tightening the connection between the port and cable

I also discovered that when I power on my Raspberry Pi, the camera has a tiny light that flashes for a while before going off. The same tiny light that was always on before.

SOMEBODY PLEASE HELP ME, this is a school assignment due tonight...

PI 3, V1.3 Camera, running latest Raspberry Pi OS 32Bit, followed this post to revert Bullseye POST

If there is a DESPERATE need to revert to the old camera stack, then it is possible. Edit /boot/config.txt, remove the line "camera_auto_detect=1", and add "start_x=1" and "gpu_mem=128". Rebooting at this stage will reload the old V4L2 driver. Stop at this point if that is sufficient for your needs.

uname -a: Linus raspberrypi 5.10.63-v7+ #1459 SMP Wed Oct 6 16:41:10 BST 2021 armv7l GNU/Linux

0

If you are asking a Question on this site you NEED to identify what OS you are using.

lsb_release -irdc will show current release.

NOTE camera support on Bullseye has TOTALLY changed and it appears you are using Bullseye on which there is currently no picamera support.

2
  • how do i check the OS im using? im new to raspberry pi. I followed a post of the raspberry pi forums whichs reverts the bullseye to the old one which if im not wrong is buster, and then ran my python program. after which the issue started happening
    – suinuj
    Nov 29 '21 at 5:56
  • I am unaware of anything "whichs reverts the bullseye to the old one" the only way to do this is restore from your backup.
    – Milliways
    Nov 29 '21 at 7:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.