1

I'm trying this 'ethernet mode' on raspberry pi zero with bullseye and bonjour installed on windows 10 following this guide Ethernet Gadget without success.

My main goal is to get control on network less environment

after editing config.txt with dtoverlay=dwc2 and cmdline.txt with modules-load=dwc2,g_ether after rootwait.

I get to this point where the raspberry pi appears in the device manager as a COM, but no RNDIS in network adapters.

and I cant use putty to connect it

this is the point I'm stuck on, I've add also ssh file to boot and I can ssh into the pi via local network

NO RNDIS

This is the message that I'm getting from putty when trying to serial connect with baud 115200

PUTTY ERROR

Does anyone manage to connect the pi in gadget mode and can assist me?

6
  • There doesn't seem to be a link to the tutorial you used...
    – Dirk
    Dec 5, 2021 at 13:05
  • @Dirk fixed it now Dec 5, 2021 at 13:27
  • how did you fix it? serial baud 9600?
    – A.J.Bauer
    Dec 26, 2021 at 7:25
  • @A.J.Bauer just fixed the link for Dirk, but please let me know if there is any new progress. Dec 27, 2021 at 7:22
  • I have the same issue with a RPi Zero 2 W. I'm using the exact same configuration as on my RPi Zero W, which is working. The only differences are A: Zero 2 W vs Zero W, B: Raspbian Bullseye vs Buster.
    – gray
    Dec 27, 2021 at 12:42

2 Answers 2

1

This is likely an issue of missing RNDIS drivers.

I worked through the same issue today, I was seeing it with both the latest Bullseye (2021-10-30) and and the current legacy Buster (2021-12-02) image of Raspberry Pi OS.

This thread helped me out, after installing the USB Ethernet/RNDIS Gadget from the optional drivers in Windows Update my Raspberry Pi was correctly identified as an network device.

0

The problem is Windows 10 unable to detect the USB Ethernet gadget. You need to install the drivers through a windows update or by a google search.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.