3

I have a Pi model 3B. I used Raspberry Pi Imager to install the latest Bullseye onto the SD card; the installation was successful. The Pi is attached to a monitor with HDMI cable.

I have VNC and SSH enabled and they working well also; both the "live screen" and the screen I see over VNC are in the correct resolution.

As soon as I booted the Pi headless, the resolution I see over VNC is dropped to 720x480. All methods of changing the resolution (In the RPi Configuration, editing the config.txt...) do not work. I do see in "Screen Configuration" that HDMI is not enabled and the Pi is outputting Composite-1

Even if I now plug in the HDMI cable and attach a monitor, I do not get an image on the monitor. Over VNC, I can see the Pi is stuck in Composite-1 mode.

Any thoughts? What I want is that I can run the Pi headless and have a 1920x1080 resolution over VNC.

1

6 Answers 6

0

The new Bullseye OS uses totally different video drivers which operate quite differently from the older video core.

To use headless there is an option to set VNC resolution in raspi-config. It CAN NOT be set in config.txt.

This was missing from the initial release and requires an update.

1
  • Thanks; that was indeed my next bet. I will stick to Buster for now
    – Daan
    Dec 7, 2021 at 9:03
3

Add ",nocomposite" to the dtoverlay line in config.txt and then you will get the headless resolution options show up in raspi-config. As detailed here by HawaiianPi.

1

For Rasbian Buster: Choose Menu, Preferences, Screen Configuration. This launches the "Screen Layout Editor. From here you can select: Configure, Screens, HDMI-1, Resolution, and pick your choice. Click on the Check mark to accept the changes and confirm when the OK button comes up. Have fun!

1

Installing a HMDI screen emulator dongle in my Raspberry Pi 3B+ worked perfectly for me. No software fiddles required. I can run the Pi headless and have a 1920x1080 resolution over VNC.

0

AS of 2/16/2023, the screen resolution problems still exit when operating headless and using VNC on either the RPI3B+ or RPI4. The only real solution I found for them that works consistently is the use of a HMDI screen emulator dongle. It is the only solution I found that makes the RPI4 work correctly.

0
0

Just manually upgraded my RaspiOS Pi4 from Bullseye to Bookworm (not a fresh install). The previously working headless screen got broken after the last package cleanup.

The solution that worked for me was to uncomment these lines in the /boot/firmware/config.txt:

# uncomment to force a console size. By default it will be display's size minus
# overscan.
framebuffer_width=1280
framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.