SD as shipped from CanaKit worked perfectly in headless mode. But on several reimagines of the SD card, when attempting to open Chrome or Firefox using RDP, the hourglass spins for a minute and then nothing. Same happened on another program trying to open a GUI of its own. I don't know what changed since the original SD other than I'm now using the latest version. And, I cannot find anything wrong other than once, I got an error message that TTY0 could not be opened due to lack of permissions. I ran this:

 pi@raspberrypi:~ $ ls -l /dev/tty0 /dev/ttyAMA0

      crw-rw---- 1 root tty       4,  0 Dec  8 09:02 /dev/tty0

      crw-rw---- 1 root dialout 204, 64 Dec  8 09:02 /dev/ttyAMA0

 pi@raspberrypi:~ $ ls -l /dev/tty1 /dev/ttyAMA0

      crw------- 1 pi   tty       4,  1 Dec  8 09:03 /dev/tty1

      crw-rw---- 1 root dialout 204, 64 Dec  8 09:02 /dev/ttyAMA0

I have little understanding of what this might be telling me. I want to use RDP rather than VNC because screen scaling on RDP is MUCH more user friendly. But I have the same issue with both.

I've searched everything I know how to search and other than others reporting the issue, there were no solutions.


1 Answer 1


I had a similar issue with a fresh install of 2022-04-04-raspios-buster-armhf.img.xz after sudo apt update && sudo apt full-upgrade. I did nothing to review log files or determine whether the minimal chromium packages were installed or to understand what the problem might be. Instead, I just did the following, and was able to load a web browser:

sudo apt remove chromium
sudo apt remove chromium-common
sudo apt remove chromium-sandbox
sudo apt install chromium-browser

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.