1

My Raspberry Pi 4 8GB RAM version with 30Oct2021 upgrade and fully updated and booting from mSD card. As the chrome browser address bar font was too small in spite of trying many options, I tried enabling pixel doubling. Thereafter, upon rebooting, screen turns black with blinking cursor. As I had a USB pen drive that was also in use earlier, I booted successfully on that. But, after enabling pixel doubling once again, I have ended up in the same situation as with the mSD card boot. I know I can reflash my boot mSD or USB and get on with it. But, whats the problem with enabling pixel doubling ? What other options can I try to get a larger address bar font ? I have tried everything I could from the web - pixel doubling was the last resort. From other trouble shooting tried Ctrl+alt+F2 - below flashes: Raspbian GNU/Linux 11 raspberrypi ttg2 (not clear) raspberrypi login:

1 Answer 1

4

If you remove --filter nearest from the end of the xrandr line in /usr/share/dispsetup.sh it should resolve your issue (on my system it looks like xrandr --output HDMI-1 --scale 0.5x0.5, but yours may be slightly different).

Looks like this is a bug in raspi-config. It's caused by a newer version of xrandr that doesn't support the --filter option, which raspi-config is not aware of. I'm not sure what other side effects this might have, I'm no expert on xrandr, but it's working fine for me.

You can log into the command line in ctrl-alt-f2 and change it there. Your pi is actually booting, so if you have enabled ssh that should still work, it's just not able to start X. Your other option to update the file is to mount your SD card to a different machine and edit it there.

Note that if you run raspi-config again and re-enable pixel doubling this change will be overwritten and you'll be back in the same boat.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.