-1

Hopefully someone has experienced this issue before but it may be a long shot... I was transferring some large files via smb to an external drive setup on my Raspberry Pi when the connection died. I wasn't able to ssh or remote into the Raspberry Pi so I did a hard reset and since then, it's unable to connect to my network at all. ifconfig shows that the eth0 network is UP, I tried reconnecting the ethernet cable, tried enabling WIFI, and tried restating the switch in which it's connected but it's still unable to connect.

Any ideas on troubleshooting or how to fix this problem?

Thanks in advance

1
  • perhaps there's something in the output of dmesg that will help diagnose the issue
    – Bravo
    Dec 9 '21 at 5:47
0

Diagnosing a corrupt OS after a crash is difficult, even for experienced users, and rarely successful.

You can try repairing the OS, which should happen automatically on reboot or you could run fsck on another Linux system.

Most of us would just restore from a backup.

If you do not have a backup the best option is to perform a fresh install. It is usually possible to recover your files.

0

Alright, it turns out there was actually a problem with the main router (router -> switch -> raspberry pi). For some reason, internet was being output from every port except for the one that was connected to the switch in which the raspberry pi was connected. A simple reboot seemed to solve the issue. Thanks everyone!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.