Some background:

Hi. I've recently been experimenting with the Raspberry Pi Camera through node.js and other languages. But, even with none of those scripts running, Pikrellcam (a live security camera software) is telling me that it can't read the data from the camera. I've tried the raspistill command and it tells me that it can't enable the camera device.

Things I've already tried:

I know that the ribbon cable is connected because the infared lights are active. (There's no SUNNY connector on this model). I've tried rebooting, sudo raspi-config --> Interfacing options --> Camera --> Enable & reboot, and, as mentioned above, raspistill. I can't tell what's wrong, but I think it's another process trying to use the camera.

My question:

How can I find out what process is using the camera, and how can I kill it?

Some notes:

I'm using a Pi Zero W 1.1 model, with a non-official Raspberry Pi camera, but it's been working up until now. It's running Raspbian Lite.

Edit 1:

vcgencmd get_camera returns both as 1. Is it possible that the camera itself is fried from static electricity? Or would that command have returned 0 if it is?

  • it's been working up until now - what did you change? these things don't stop working without changing something - I gather you're running Buster, not Bullseye? If so, what's the output of vcgencmd get_camera
    – Bravo
    Dec 11, 2021 at 1:05
  • @Bravo I didn't really change any settings or anything. See the edit to my post for output of vcgencmd. Dec 11, 2021 at 15:24
  • camera is detected - so, it's not "fried from static"
    – Bravo
    Dec 11, 2021 at 23:58


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.