1

I recently created a Windows 11 Pro ARM64 .iso through uupdump.net aria2c to .iso conversion everything went fine the .iso was made i then launched WoR (Windows on Raspberry) everything was done correctly i used the default option apart that i selected wimlib as the install and choose to use lzx compression, my Raspberry Pi is the 4B model the eeprom was updated to usb-boot, it is the model with 4Gb of ram, i am also using a 64Gb Kingston 3.0 usb, once it installed correctly i ejected the usb from my pc, Then i plugged into the Rapberry Pi, plugged in ethernet, plugged in my keyboard, connected it to my monitor and then plugged it into the power outlet, it booted up fine via the usb 3.0 port, i ajusted the setting, display: 720p, ram: use all ram. saved, exited BIOS, pressed enter to boot, then it just kept on the boot screen for 10 mins, then it started verbosing, it just said two lines: no internet connection detected, no internet connection detected, and stayed like that on the boot screen. Am i missing any steps on how to do this? Or is this a common issue? Edit: I tried rebooting several times, after two reboots it finally just gave the rainbow screen.

1 Answer 1

2

Booting Windows on Raspberry Pi is not fast enough compared to PCs, but some options can help you anyway:

  1. Use fast 100 MB/s U3 Class 10 SD card (like SiliconPower Superior Pro)
  2. Change the boot order in the boot option to disable the UEFI ethernet check.
  3. Be a little bit patient :)

And for better performance:

  1. Disable transparent effect in windows.

  2. Change the performance option : Right-click on This PC > Properties > Advanced system setting > Performance > setting > Adjudt for best performance

  3. Install IoT Enterprise version that is lighter than the Pro version.

2
  • 1
    The OP actually says "not booting" in the titlle and "kept on the boot screen for 10 mins". 10 as in minutes. Are you saying that the solution is simply to "Be a little bit patient"?!? What would be too long -- a few hours? Two weeks?
    – goldilocks
    Dec 14, 2021 at 16:55
  • 1
    @goldilocks I just said it's not fast compared to PCs :) When I tried to boot windows on RPi using the U1-SD card I waited almost 10 minutes, but with the U3-SD card, it was 2 min. Flashing windows on U1 was 5 hours but in U3 was 18 minutes. Booting on U1 was 10 or 15 min but on U3 was 2 or 3 minutes. U3 is so good :)
    – Pouya
    Dec 15, 2021 at 7:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.