0

I have installed pi-hole on two Raspberry Pi 4 devices. Both are connected to my network and working.

I have an ATT router, so I cannot change the DNS servers in the router. I am attempting to set dns on Windows 10 client. I changed the ethernet ipv4 settings in Windows to use my two pi-hole servers.

When I do "ipconfig/all", the two servers do appear in the ethernet adapter, but also the ipv6 address of the ATT router:

ipconfig/all

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . : attlocal.net
   Description . . . . . . . . . . . : Realtek Gaming GbE Family Controller
   Physical Address. . . . . . . . . : <physical address>
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : <router ipv6 prefix>::24(Preferred)
   Lease Obtained. . . . . . . . . . : Thursday, November 11, 2021 12:54:44 PM
   Lease Expires . . . . . . . . . . : Wednesday, January 12, 2022 8:56:57 PM
   IPv6 Address. . . . . . . . . . . : <router ipv6 prefix>:89ef:f9c5:f931:e119(Preferred)
   Temporary IPv6 Address. . . . . . : <router ipv6 prefix>:1464:90cd:ba50:5066(Deprecated)
   Temporary IPv6 Address. . . . . . : <router ipv6 prefix>:25ec:f00d:8077:14f1(Deprecated)
   Temporary IPv6 Address. . . . . . : <router ipv6 prefix>:5856:c966:db86:bdb3(Preferred)
   Temporary IPv6 Address. . . . . . : <router ipv6 prefix>:5d36:39e5:26c9:b214(Deprecated)
   Temporary IPv6 Address. . . . . . : <router ipv6 prefix>:9caf:57c6:dbf0:f30a(Deprecated)
   Temporary IPv6 Address. . . . . . : <router ipv6 prefix>:bde9:80d1:dea:e36d(Deprecated)
   Temporary IPv6 Address. . . . . . : <router ipv6 prefix>:cd73:26e:f2bc:edd4(Deprecated)
   Link-local IPv6 Address . . . . . : <don't know what this is> (Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.248(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Thursday, November 11, 2021 12:54:43 PM
   Lease Expires . . . . . . . . . . : Wednesday, December 15, 2021 6:33:14 PM
   Default Gateway . . . . . . . . . : <default gateway>
                                       192.168.1.254
   DHCP Server . . . . . . . . . . . : 192.168.1.254
   DHCPv6 IAID . . . . . . . . . . . : <DHCPv6 IAID>
   DHCPv6 Client DUID. . . . . . . . : <DHCPv6 Client DUID>
   DNS Servers . . . . . . . . . . . : <router ipv6 address>
                                       192.168.1.158
                                       192.168.1.159
                                       <router ipv6 address>
   NetBIOS over Tcpip. . . . . . . . : Enabled
   Connection-specific DNS Suffix Search List :
                                       attlocal.net
                                       attlocal.net

The other adapters are disabled, except for vEthernet (wlan). When I disable it, I get the same results.

My question: Is there a way to make Windows 10 ONLY use the dns servers I enter into ipv4 properties for my ethernet adapter? Is there a way to make it NOT include the router (for dns)?

5
  • this question seems to have nothing to do with raspberry pi - you may get an answer on a forum that deals with Microsoft Windows instead
    – Bravo
    Dec 15, 2021 at 3:37
  • I posted this under the assumption I was posting in an area concentrated on pi-hole (a raspberry pi specific application) installation and maintenance. In order for pi-hole to work, it must be set as the dns server for the client either configured in the client or the router of the network the client is attached to. How to resolve this in Windows with a router that does not allow you to set dns would certainly be a pi-hole issue if you're trying to get it to work in that environment. If this is not the purpose of this forum, oops, my bad. Dec 15, 2021 at 4:13
  • In order for pi-hole to work, it must be set as the dns server for the client either configured in the client which is not a raspberry pi or the router of the network the client is attached to which is not a raspberry pi either - all I said was you're better off asking about a windows 10 issue on a forum that targets windows 10 issues - I did not say you can't ask the question
    – Bravo
    Dec 15, 2021 at 5:07
  • No question that the question I asked required a Windows (non-rpi) solution. I just think that people in this forum would understand the context a lot better than folks just looking at it as a Windows issue. I googled "att router pi-hole" and found a bunch of suggestions regarding altering dhcp, ip-passthrough and disabling ipv6. So far, not one that recommends using ipv6 addresses of pi-hole servers. Also, I'm glad I posted here because if anyone else runs into the same problem, this solution will now be available as an option. But, I will be mindful of your comments in the future. Dec 15, 2021 at 5:24
  • people in this forum would understand the context a lot better than folks just looking at it as a Windows issue - good point, windows users generally know nothing - however, in the appropriate forum (not sure which stack exchange forum is the appropriate one, probably one with a large font) you'd think they'd know how to do things :p
    – Bravo
    Dec 15, 2021 at 7:02

1 Answer 1

0

I found the answer to my question. When pi-hole completes it's installation, it shows you a screen with the password to the local web site. On that screen, it shows the ipv4 address and the ipv6 address of the local server.

pi-hole install final screen

Enter the ipv6 address into the ipv6 ethernet adapter properties of the Windows 10 client. This will replace the default router address.

I brought up two pi-hole servers, and entered both ipv4 and both ipv6 addresses as primary and secondary dns servers in the Windows client ethernet adapter properties for ipv4 and piv6 respectively. Now when I do ipconfig/all, I only see the ipv4 and ipv6 addresses of my pi-hole servers as dns servers for the adapter.

Success!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.