1

I have a sound problem with my Pi running Raspbian. I am using a HD monitor connected to my pi via a HDMI cable (it doesn't have internal speakers).

When the sound setting is on Auto my sound via headphones doesn't work.

I have to manually set Force 3.5mm ('headphone') jack when I want to listen with headphones.

I accessed these settings by typing:

sudo raspi-config

then changed to headphone mode under Advanced Options --> Audio

What I want is for sound to play through headphones, when audio set on auto, since I also connect my pi to my TV.

  • Do you have to connect to your tv with HDMI? Can you use av cables to connect your tv to your pi? Your HDMI is probably taking both the video and audio feed on boot. – Dom Feb 3 '14 at 17:42
  • When I connect pi to TV via HDMI cable there is also no sound when its on auto setting, but if I choose Force HDMI it works. When changing sound option I dont need to reboot as it takes effect straight away – synthesis Feb 4 '14 at 8:51
  • Forgot to mention also tried using vga connection (using HDMI to VGA adapter) but same issue as above – synthesis Feb 4 '14 at 8:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.