0

I'm trying to setup my raspberry pi to be a multimedia center, using raspbmc.

I've installed the OS to the card and configured it on the first boot. Currently I'm accessing it through wired connection and SSH from my main computer. However I want to use a LogiLink WL0084B USB WiFi adapter to have access to the pi on the living room (where there is no wired connection available).

So I'm not exactly a linux guru... my linux skills are quite cheap and I'm facing some trouble trying to compile the drivers.

I'm trying to follow the instructions on this link: http://www.linux-hardware-guide.com/es/2013-10-03-logilink-wl0084b-wlan-nano-adapter-150mbps-usb-2-0

I've donwloaded the driver, unpacked it and created the symlink, however I get the following error after trying to build the driver:

sudo dkms build -m Ralink_5370sta -v 2.5.0.3

returns:

Error! Bad return status for module build on kernel: 3.10.24 (armv61)
Consult /var/lib/dkms/Ralink_5370sta/2.5.0.3/build/make.log for more information

The result of doing a cat of that filelog is:

DKMS make.log for Ralink_5370sta-2.5.0.3 for kernel 3.10.24(armv61)
Wed Feb 5 21:44:02 CET 2014
make: Entering directory `/var/lib/dkms/Ralink_5370sta/2.5.0.3/build/src'
make -C tools
make[1]: Entering directory `/var/lib/dkms/Ralink_5370sta/2.5.0.3/build/src/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory `/var/lib/dkms/Ralink_5370sta/2.5.0.3/build/src/tools'
`/var/lib/dkms/Ralink_5370sta/2.5.0.3/build/src/tools/bin2h
cp-f os/linux/Makefile.6 /var/lib/dkms/Ralink_5370sta/2.5.0.3/build/src/os/linux/Makefile
make -C /lib/modules/3.10.24/build SUBDIRS=/var/lib/dkms/Ralink_5370sta/2.5.0.3/build/src/os/linux modules
make[1]: Entering directory `/lib/modules/3.10.24/build'
make[1]: *** No rule to make target `modules'. Stop.
make[1]: Leaving directory `/lib/modules/3.10.24/build'
make: *** [LINUX] Error 2
make: Leaving directory `/var/lib/dkms/Ralink_5370sta/2.5.0.3/build/src'

I'm not ashamed to say that, although I'm more or less able to follow what is happening on the log, I have absolutely no idea about what "* No rule to make target `modules'. Stop." means or how to fix it.

Any insight on this will be much appreciated. I'm trying to learn a bit about linux, this is why I bought the raspberry, and a documented answer will be much more welcomed that just a script to run blindly.

Ok... more info on this topic so far.

Googling for a while I've learned that what I've downloaded are the generic linux headers, while, somewhat, driver's Makefile is seeking the headers of my current kernel (3.10.24), which I'm being unable to download.

The error I've getting when trying to build the driver seems to come from here. Now, if I manage to install the correct headers maybe I'll be able to compile it.

Any help with this?

Thanks.

0

Ok, finally I solved the problem, not how I was expecting, but I've finally enabled WiFi on the raspberry.

From all I've readed, the WL0084B is a well known and supported dongle, so, at least teoretically, raspbmc should be able to use it out of the box without extra drivers.

I've reinstalled the system on the SD Card, but this time I ticked the option of manually configure network.

I've passed wifi data to the configuration, started the system plugged to the WiFi dongle and it just worked.

I thought this could be useful for other people out there trying to get a wireless device.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.