2

Firstly, I apologize for any semantic errors in the title with respect to x264. Also, yes I have tried to find other similar posts on this and other sites. I haven't been able to find any answers that work via multiple search engines.

PROBLEM

I see artifacts when I try to view anything encoded for x264. Often these artifacts will encompass nearly the whole screen. This happens irrespective of audio codec or resolution (tested 720p and 1080p). The sound works flawlessly and no video stuttering. The following is an extreme example of what happens: http://i.stack.imgur.com/Jnbbn.png

Why am I seeing these artifacts and can this problem be fixed? If so, how? If not, why?

SET UP

I'm using the 512MB version of the Raspberry Pi and have Raspbmc installed (one of the latest git builds). I've tried multiple versions of Raspbmc (including release) without success. I've purchased and verified installation of the proprietary codecs sold on the Raspberry site. The following shows the BD Player audio support that the Pi is connected to via HDMI:

/opt/vc/bin/tvservice -a

PCM supported: Max channels: 2, Max samplerate: 96kHz, Max samplesize 24 bits.
AC3 supported: Max channels: 6, Max samplerate: 48kHz, Max rate 640 kb/s.
DTS supported: Max channels: 6, Max samplerate: 48kHz, Max rate 1536 kb/s.

CONFIGURATION

My config.txt resembles the following:

arm_freq=850
core_freq=375
force_turbo=1
disable_overscan=1
decode_MPG2=0x■■■■■■■■
decode_WVC1=0x■■■■■■■■
gpu_mem=128
start_file=start_x.elf
fixup_file=fixup_x.dat
hdmi_ignore_cec_init=1
no_hdmi_resample=1
hdmi_stream_channels=1

I'm using audio pass-through to my BD Player as far as I can tell from the XBMC settings. That is, I have the DTS and AC3 options selected in the audio settings menu.

Example Video File Properties

Unable to place links due to low reputation.

  • Do you have the same problem with different video files? Try bumping up your gpu_mem to 256. I don't think that'll do it, but it might and it's easy. – einnocent Feb 6 '14 at 16:20
  • So far I've only seen this issue with x264 in an mkv container. I have 1080p avi files I can play perfectly well. I doubled the amount of allocated ram allocated to the GPU to 256MB. It's as you predicted, no change. – Derrekito Feb 6 '14 at 18:30
  • Does that mean you don't see the problem with x264 in an mp4 container? – einnocent Feb 6 '14 at 18:35
  • It does seem to be the same codec. I'm not certain. So MP4 appears to work fine. The working example below is an MP4. The broken one is a mkv. This doesn't work: pastebin.com/PsTxCLPc This does work: pastebin.com/hacE62Au – Derrekito Feb 6 '14 at 19:25
  • pastebin.com/b5qrjB2w This is another mkv but with very similar properties as that working MP4. This still shows artifacts although not as severe as my first broken example. – Derrekito Feb 6 '14 at 19:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.