2

Model B, Raspbian, Wi-Pi vs Macbook Pro

Setup

  • Both devices are sitting right next to eachother
  • Connected to the same router.
  • traceroute is the same for both
  • Even typing on the Pi via SSH feels slow

Is there any way to get the latency down?

R.Pi

64 bytes from 4.2.2.1: icmp_req=185 ttl=54 time=489 ms
64 bytes from 4.2.2.1: icmp_req=186 ttl=54 time=718 ms
64 bytes from 4.2.2.1: icmp_req=187 ttl=54 time=536 ms
64 bytes from 4.2.2.1: icmp_req=188 ttl=54 time=563 ms
64 bytes from 4.2.2.1: icmp_req=190 ttl=54 time=409 ms
64 bytes from 4.2.2.1: icmp_req=191 ttl=54 time=429 ms
64 bytes from 4.2.2.1: icmp_req=192 ttl=54 time=453 ms
64 bytes from 4.2.2.1: icmp_req=193 ttl=54 time=476 ms
64 bytes from 4.2.2.1: icmp_req=194 ttl=54 time=183 ms
64 bytes from 4.2.2.1: icmp_req=196 ttl=54 time=344 ms

OS X

64 bytes from 4.2.2.1: icmp_seq=180 ttl=54 time=182.338 ms
64 bytes from 4.2.2.1: icmp_seq=181 ttl=54 time=181.657 ms
64 bytes from 4.2.2.1: icmp_seq=182 ttl=54 time=181.700 ms
64 bytes from 4.2.2.1: icmp_seq=183 ttl=54 time=182.498 ms
64 bytes from 4.2.2.1: icmp_seq=184 ttl=54 time=181.373 ms
64 bytes from 4.2.2.1: icmp_seq=185 ttl=54 time=187.886 ms
64 bytes from 4.2.2.1: icmp_seq=186 ttl=54 time=181.224 ms
64 bytes from 4.2.2.1: icmp_seq=187 ttl=54 time=185.362 ms
64 bytes from 4.2.2.1: icmp_seq=188 ttl=54 time=180.515 ms
  • bad power supply most likley reason. the Wifi doesnot have enough juice to go full power. – Piotr Kula Feb 6 '14 at 18:39
  • @ppumkin, in hopes, I changed it to a 1A powersupply and still no luck. thanks though. – nitsujri Feb 7 '14 at 1:03
  • Yea... I gave up with WiFi on my Pi because I had the same problem.. but your using WiPi....? NOt sure what the problem is :( – Piotr Kula Feb 7 '14 at 9:38
0

I found one thread where a guy had trouble streaming at 720p with the WiPi. He overclocked it and he got a lot closer to 720.

It works.

pi@raspberrypi:~$ ping 4.2.2.1
PING 4.2.2.1 (4.2.2.1) 56(84) bytes of data.
64 bytes from 4.2.2.1: icmp_req=1 ttl=54 time=179 ms
64 bytes from 4.2.2.1: icmp_req=2 ttl=54 time=177 ms
64 bytes from 4.2.2.1: icmp_req=3 ttl=54 time=251 ms
64 bytes from 4.2.2.1: icmp_req=4 ttl=54 time=177 ms
64 bytes from 4.2.2.1: icmp_req=5 ttl=54 time=177 ms
64 bytes from 4.2.2.1: icmp_req=6 ttl=54 time=178 ms
64 bytes from 4.2.2.1: icmp_req=7 ttl=54 time=178 ms

My settings from here in /boot/config.txt:

arm_freq=1000
core_freq=500
sdram_freq=500
over_voltage=6
force_turbo=0

These settings are safe as long as force_turbo=0 via here, here, here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.