0

I have a Python Script which takes input from a USB camera to monitor the face. The script runs as expected and runs automatically on start up when connected to a monitor.

However, I need the script to run when the Pi is not connected to a monitor. The Pi boots up as expected, but the USB camera light never turns on, thus the script does not run when a monitor is not connected.

I have tried setting a default resolution with sudo raspi-config > Display Options > Resolution but when I click this, nothing happens and I'm taken back to the terminal.

I am running Raspbian Buster Desktop on the Pi 4.

1

SOLVED:

I needed to force HDMI output. I did this by opening:

sudo nano /boot/config.txt

and uncommenting the line:

hdmi_force_hotplug=1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.