I'm trying to install Webmin on raspberryOS bullseye 32bits (5.10.87-v7l+ kernel), and the installation get stuck on: "Unpacking webmin (1.983) ..."

I already try to install over 2 methods:

  1. Adding "deb https://download.webmin.com/download/repository sarge contrib" to "/etc/apt/sources.list"
  2. wget https://download.webmin.com/jcameron-key.asc
  3. apt-key add jcameron-key.asc
  4. apt-get install Webmin

And 2nd method:

  1. wget https://prdownloads.sourceforge.net/webadmin/webmin_1.983_all.deb
  2. dpkg --install webmin_1.983_all.deb

Both get exactly the same result. I try to install an old version (v1.920) over dpkg, I reach the end of installation with success. But when I try to upgrade in the webUI for v1.983 (because of security issues), I end with the same result: crash and I get a error:

Error. 500 - Perl execution failed - Undefined subroutine &main::authentic called

If I refresh the WebUI I get:

Error - Perl execution failed

Undefined subroutine &WebminCore::theme_get_webprefix_local called at /usr/share/webmin/authentic-theme/authentic.pl line 1311. Compilation failed in require at /usr/share/webmin/webmin/upgrade.cgi line 5.

Later the only way to remove it from system is using:

$ dpkg --remove --force-remove-reinstreq webmin

Also I try to use apt to do the installation, and check the progress, but after 1 hour still stuck at 20%:

$ sudo apt install ./webmin_1.983_all.deb 
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Note, selecting 'webmin' instead of './webmin_1.983_all.deb'
The following NEW packages will be installed:

0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/28.1 MB of archives.
After this operation, 302 MB of additional disk space will be used.
Get:1 /home/pi/webmin_1.983_all.deb webmin all 1.983 [28.1 MB]
(Reading database ... 100909 files and directories currently installed.)
Preparing to unpack /home/pi/webmin_1.983_all.deb ...
Unpacking webmin (1.983) ...

Progress: [ 20%] [###########...............................................] 

Anyone facing the same problem with bullseye? There is another way to install it, like docker/portainer instead?

  • get stuck on: "Unpacking webmin (1.983) ..." ... just trying this on a pi3 (so, a bit solwer than a pi4) ... it took about 5 minutes ... have you tried using some patience?
    – Bravo
    Dec 21, 2021 at 1:16

1 Answer 1


Following the comment of the user Bravo, I left installing during a half a hour, take a coffee and come back, and was done! Installed with success!

I guess the best explanation for this RPi 4 (4Gb) it's using an old SATA 2.5 1Tb hard drive 5400 rpm as a main and boot drive over USB3, is about 10 years old and probably high fragmented (S.M.A.R.T. already show me some red flags) and took much more time... than a SD.

Also this thread it's 30 days old, maybe some OS update could make this work today.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.