0

I was not successful getting into initramfs shell (busybox) on the most recent Raspbian 64-bit release. Every time the system should fall back into the initramfs, I just get an unresponsive serial console via gpio connector and a black HDMI screen.

Any advice for this?

I made the following changes to /boot/config.txt:

hdmi_force_hotplug=1
hdmi_group=1
config_hdmi_boost=9
enable_uart=1
initramfs initramfs.gz followkernel

1 Answer 1

0

I tried looking up some information for you to help. But, according to this reference:

config.txt

It says:

If you are seeing HDMI issues (speckling, interference) then try 7. Very long HDMI cables may need up to 11, but values this high should not be used unless absolutely necessary.

So, in other word, try this:

Change:

config_hdmi_boost=9

To:

config_hdmi_boost=7

Or To:

config_hdmi_boost=11

This section on the same reference addresses other HDMI options.

1
  • Thank you for the answer. I am not sure if this is really a problem of the HDMI setting. When I boot from vanilla SD-card, there are no problems and I also can use the desktop. The difficulty only arrives when the system should enter initramfs. On ubntu-arm I also have no problems.
    – northcom
    Dec 23, 2021 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.