0

I have a Raspberry Pi 4 running Debian 11 (bullseye), however, it doesn't boot when a monitor is not connected. When the monitor is connected, it boots perfectly, however without it it stalls forever while booting. When it does this, I can't ssh or connect to it remotely.

The /var/log/messages says:

Dec 27 23:15:07 debian-pi kernel: [   20.451738] vc4-drm gpu: [drm] Cannot find any crtc or sizes
Dec 27 23:15:17 debian-pi kernel: [   30.855155] Console: switching to colour frame buffer device 240x67
Dec 27 23:15:18 debian-pi kernel: [   30.955513] vc4-drm gpu: [drm] fb0: vc4drmfb frame buffer device
Dec 27 23:16:15 debian-pi kernel: [   52.129976] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

after booting without monitor

4
  • There's not enough information here to narrow down your problem. Have you tried looking at /var/log/messages, /var/log/syslog, etc. for a possible cause/error messages?
    – JamieSee
    Dec 27, 2021 at 22:56
  • @JamieSee I added the messages added to /var/log/messages when it was booted without a monitor.
    – Brendan R.
    Dec 27, 2021 at 23:18
  • Try setting resolutions and HDMI modes explicitly in /boot/config.txt, see raspberrypi.com/documentation/computers/…
    – 0__
    Jan 7, 2022 at 15:02
  • What do you get if you comment out dtoverlay=vc4-kms-v3d in your config.txt? There are some indications that the vc4 driver behaviors can cause long delays between boot and the system responding. Also see this thread forums.raspberrypi.com/viewtopic.php?t=277953.
    – JamieSee
    Jan 18, 2022 at 20:06

1 Answer 1

1

Here are a few things to try based on several threads that I found regarding video related Pi 4 boot issues.

Update the firmware in the eeprom but make sure you have backups of anything important and stable power. Problems are rare but can have issues up to and including bricking the Pi. Be careful and make sure that you understand the process.

sudo apt update
sudo apt upgrade
sudo rpi-eeprom-update
# make note of the eeprom version
sudo rpi-eeprom-update -a
reboot

After rebooting run the command again and check the version.

sudo rpi-eeprom-update

If that does not fix the problem, then do the following.

Try disabling the vc4 driver by editing /boot/config.txt to comment out this line:

dtoverlay=vc4-kms-v3d

See this thread Bullseye vncserver is very slow without display on the Raspberry Pi Forums which seems to be similar to your problem.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.