0

My Pi4B wouldn't boot up the other day and have been trying many different things with no luck. I have everything unplugged from it except the official power supply. With or without the SD card inserted I'm getting 3 long followed by 3 short flashes of the green led and a solid red.

I got a brand new SD card (San Disk Extreme 32Gb) and burned latest Rasbian using PiImager and I am getting the same behavior. I also have tried without the SD card and with the HDMI plugged in. According to the Pi official docs i should at least see a bootloader diagnostic screen - which i don't. So I am thinking maybe my EEPROM or something like that needs to be "rescued"?

I also downloaded the latest eeprom recovery image (https://github.com/raspberrypi/rpi-eeprom/releases) and used the PiImager to create both a USB and a SD version of a recovery. Tried to boot with both and same behavior - as soon as i plug in power it starts the 3long/3short pattern as if its failing immediately. I also burned a SD card from the "Misc utility->bootloader->SD Card Boot" option.

Deep deep in the docs i found the error fo 3L/3S green - "I2C error - Pi 4". Can anyone point me to reasons for this and/or potential resolutions - or did i somehow fry my board...

1
  • So I am thinking maybe my EEPROM or something like that needs to be "rescued"? that's what I would do - though if the pattern is the same regardless of the presence or absence of sd card, and it's a pattern that isn't documented - you may have trouble with a rescue flash - still, give it a go
    – Bravo
    Dec 29, 2021 at 21:46

1 Answer 1

0

See Pi4 Boot Problems Sticky

There is nothing that matches, so maybe you need to recount. The documentation may be slightly out of date.

3
  • I eventually found a larger table in the official raspberry pi docs that indicates 3L/3S is "I2C error - Pi 4". But i've found nothing more about this error during boot up. I know what IC2 is and i assume that upon powering up the CPU isn't able to talk to another chip - or maybe its the other way around
    – DaveInPA
    Dec 29, 2021 at 23:54
  • @DaveInPA Could you post the link. The Pi uses I²C to configure an expander chip which controls on board functions (including LEDs.) Unfortunately this is probably a hardware failure.
    – Milliways
    Dec 30, 2021 at 0:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.