0

I have an old Pi-3 running Stretch. I have what apt-get install tells me is the latest version of everything installed. I plug in an old HP PSC 750xi All-In-One USB printer/scanner. The Pi recognizes the printer features of the device and I can successfully configure CUPS to use the printer. But I cannot get the Pi to recognize the device's scanner.

I have a separate laptop running Ubuntu 20. When I plug the USB device into that laptop, I can use hplip's hp-scan tool to successfully scan. But none of the Pi's hplip tools (hp-setup, hp-probe, hp-check, hp-scan, scanimage, ...) recognize the USB scanner.

Clearly, as the Ubuntu test proves, hplip does support scanning for this all-in-one printer/scanner. And hplip documentation indicates that the device is supported both for the Pi hplip version (3.16.11) and for the Ubuntu version (3.20).

I also have an HP 6978 Network printer/scanner that the Ubuntu system sees on the network and can manipulate with the hplip tools. The Pi's CUPS server sees and can use that network printer. But, like the USB device, the Pi fails to 'see' the network scanner.

My understanding is that these scanners are supported through use of the libsane-hpaio backend. Yes, I have installed the libsane-hpaio package on the Pi. I've run scanimage on the Pi with SANE_DEBUG_DLL=128 and SANE_DEBUG_HPAIO=128 but the output simply reports no scanners found without indicating any errors of any kind. On the Ubuntu system, the same debug output shows successful discovery of both the network scanner and the USB-connected scanner.

I cannot find any missing packages or dependencies on the Pi. I have tried removing and re-installing hplip and a number of other packages. Clearly, there is some configuration difference between the Pi and the Ubuntu platforms. But after several days of struggle, I'm stumped.

Anyone have any ideas?

0

After much additional struggling in vain, I abandoned my quest to make my original pi work. I simply took a new SD card and rebuilt the system from scratch using the current Raspberry Pi OS Buster image. With that image, I just plugged the printer/scanner into the USB port and both printing and scanning to the HP PSC 750xi worked 'right out of the box' with no additional configuration whatsoever. I suspect my original SD card had acquired some bizarre mismatch of packages/versions over the years that was just too subtle for me to identify and correct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.