5

I have a 512MB Model B (2012 edition I believe, possibly 2011...china made) and recently my power cord was partitally chewed through. Obviously, the Pi wouldn't boot up, as I noticed when I tried to SSH in.

So, I swapped out the power cord, but nothing happened. I watched the Pi as I plugged in the power cord and the red PWR LED simply slowly died, and nothing would come up on the screen. So, I thought, I'll just give it a rest for a day, seeing as it was up as a Spigot MC server 24/7 for quite some time. I let it sit for a day, and then booted it up again. This time, the PWR LED stayed on and the green ACT LED flickered, showing activity, but when I tried to SSH in, I got ssh: connect to host 192.168.0.104 port 22: No route to host. I plugged in a screen via HDMI and I get the boot, but it seems different. Other than that the rainbow splash doesn't show up at all, I'm not sure what is different, but it is most definitely different.

Must be the router not recognizing the Pi, not sure why, but whatever. I swapped out the ethernet cable, but still nothing. I watched the Pi during a reboot and the Ethernet LEDs didn't come on and the Pi's static IP (which I know works, it worked for quite a while) wasn't displayed.

So, I was going to get some data from the Pi (eg. see if I could ping the router check if my static IP setup was still in place, etc.).

However, neither my Bluetooth keyboard (which does work with the Pi, have used it before) nor my Mechanical keyboard connected through a powered hub (also works, hub is confirmed to work and I have used it successfully before) were recognized.

So, I went a hunting and on the R-Pi Troubleshooting e-linux page, I found this:

No USB device works, with known good PS, SD card, KB

There has been more than one report[13][14][15] of a R-Pi booting but not getting USB input, using a known-good power supply, SD card, and keyboard. The more common cause for no USB devices working is low power supply voltage from bad PSU, cable, or USB hub, but in this case the problem was no clock signal present at the LAN9512 USB/Ethernet chip "IC3", and the solution was to reflow the solder on the 25 MHz crystal "X1" on the bottom side of the board. Or return the board for a replacement, but before making this conclusion, confirm known good peripherals. A significant number of USB keyboards are not compatible with R-Pi. As of June 1 2012, Eben reported[16] that only about 1 in 1000 shipped R-Pi boards have been found to have a hardware fault of any kind.

which perfectly describes my issue, but I have no clue why this hasn't popped up before!

I am going to re-image another SD card and see if that works, but I really hope that this hasn't fried my Pi's ethernet and USB ports!

Basically, my questions are,

  • Does anyone know why the ports might not be being recognized
  • Does anyone know of a way to fix it.
  • I am sorry that your RPi does not work, but what actually is the question here? – myhd Feb 15 '14 at 8:54
  • @myhd Thank you for pointing that out. I thought I had made it clear with the title, but I have since fixed it. – RPiAwesomeness Feb 15 '14 at 23:03
  • Do you have soldering equipment? – Bex Apr 20 '14 at 8:30
  • @Bex Yes, I do have soldering equipment and I have tried re-flowing the solder on the X1 crystal, but I didn't try very hard, I'm going to attempt it again. – RPiAwesomeness Apr 20 '14 at 11:46
  • @RPiAwesomeness Go for it! Good luck! I love the smell of soldering in the morning! – Bex Apr 20 '14 at 11:54
2

It looks like a power issue, have you tried this cable with anything else - phone, another Pi, etc. I think that if the Pi wasn't getting enough power, USB and Ethernet wouldn't work.

  • 1
    Yes, I have tried a separate power cord as well as multiple other wall warts. Nothing is working. Thanks for trying to help! – RPiAwesomeness Mar 11 '14 at 17:36
  • 1
    Ok, so what exactly happens when you plug it in? Which LEDs light up (or don't) etc. And have you checked that the SD card isn't corrupted or was it working fine before the cable was chewed? – developius Mar 13 '14 at 12:16
  • Sorry about the delay, I didn't get a notification when you commented here, you didn't put my username in (like @RPiAwesomeness). Anyways, the Red PWR/Green ACT LEDs light up, like I said in my post. I've checked and the SD card isn't corrupted, Ubuntu can read/write just fine and the Pi boots, but there is no USB/Ethernet. I can use it via the Serial Console cable, but not with a screen/keyboard. As far as I know it was working just fine and dandy before the cord got chewed. I was able to connect/play on the MC server just fine. – RPiAwesomeness Mar 24 '14 at 15:47
2

I had the same issue with the Raspberry Pi 2 model.

After a period of continuously being plugged in and forgotten about, I decided I wanted to update its OSes, only to find out none of the USB ports worked. I tried multiple power supplies and multiple keyboards/mice that I knew were good.

This was not only in the OSes themselves, but in the interactive NOOBS as well.

So I decided to give the suggested reflow a go.

I do not own a reflow station, however I've reflown both laptop and desktop GPUs before (successfully) using a heatgun. There is always risks when doing it like that, but I figured I did not have much to lose since I needed more than just SSH support.

In my case, I had Ethernet, so I figured it's not the chip. From what I know the RPI2 handles both the USB and LAN communication via the same controller.

You may or may not want to attempt the below procedure on the USB/LAN controller chip as well.

So, I reflowed the X1 crystal, and the F1 fuse just in case (bear in mind that heating up a fuse will likely reduce its lifespan). My heatgun extension has a circular end with a 2.5cm diameter, so it's not like this was a precise job.

Before proceeding, bear in mind that doing it this way carries all sorts of risks, like damaging other components on the board, so you could end up with a completely dead Pi instead of a half-dead one.

My heatgun has a temperature indicator, but the following can be done with a multimeter temperature probe as well. There are reflow attempts on the internet that suggest utilizing a kitchen stove, but I would personally not recommend doing that because there are plastic components that could melt, and SMD components on the other side of the board that could fall off.

I was working with the assumption that Lead-free solder was used (like 60/40 Sn-Pb) which generally melts at 188 °C, so I did the following over the course of several minutes, over a low-blow setting to minimize the risk, never staying in the same exact spot for too long:

  • set the board on a flat area (like a wooden cutting board), suspended by the USB ports and a balled-up piece of aluminuim foil under the onboard display connector. The to-be-reflown components are on the opposite side of the Broadcom chip, i.e. the bottom side.
  • heated the area around and over X1 to 120 °C for one minute
  • heated the area around and over X1 to 180 °C for one and a half minute
  • heated the area around and over X1 to 220 °C for two minutes (to make sure no temperature was lost in the distance between the heatgun tip and the board)

I did this from a distance of 5-10cm, always moving about in circular motions. I repeated the same for the fuse, although for shorter periods of time. I believe around 2 minutes all in all at 200-220 °C.

After you're done, leave it for at least 5 minutes to cool, and another 5 if it's still unbearably hot to the touch. I would have left it longer but just wanted to move it away from the same physical spot which had absorbed a lot a heat as well. Then leave it for at least another 10 minutes. If it doesn't work on the first try, you may want to leave it for a few hours for the fuse to reset.

When I plugged the PI everything was working well on the first try. Hope this helps you, and other people unfortunate enough to get afflicted by this.

1

It might be your router has assigned it another ip-address at this boot. If your router has a user interface, you might want to check if it shows up there, and what ip it gets. That way you might be able to ssh into it after all.

  • 1
    I don't think that is the issue, as the both the Ethernet and USB aren't working, and there is a known issue where the X1 crystal stops oscillating, and, because the Ethernet and USB both go through the same controller on the chip, they both go down. I think that is what is affecting me. – RPiAwesomeness Apr 20 '14 at 11:48
1

I watched the Pi as I plugged in the power cord and the red PWR LED simply slowly died

Board issue, the Pi probably shorted and fried something on the board. Take it to an electronist, a shop that fixes TVs and such and they'll fix it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.