0

I was in the middle of upgrading to Bullseye from Buster when my SSH session failed, and I couldn't ssh into the machine anymore. I rebooted it, and now am presented with this problem.

I have attempted --fix-broken but it just outputs the same thing over and over again. I think I would want to install the baseline version of packages for bullseye I should be set, I have nothing mission critical going on here, just am unsure how to untangle the currently installed packages.

pi@pihole:~ $ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 bsdmainutils : Depends: ncal but it is not installed
 libc-bin : Depends: libc6 (< 2.29) but 2.31-13+rpi1+deb11u2 is installed
 libc-dev-bin : Depends: libc6 (< 2.29) but 2.31-13+rpi1+deb11u2 is installed
 libc6-dbg : Depends: libc6 (= 2.28-10+rpt2+rpi1) but 2.31-13+rpi1+deb11u2 is installed
 libc6-dev : Depends: libc6 (= 2.28-10+rpt2+rpi1) but 2.31-13+rpi1+deb11u2 is installed
 locales : Depends: libc-bin (> 2.31) but 2.28-10+rpt2+rpi1 is installed
 openssh-sftp-server : Depends: openssh-client (= 1:7.9p1-10+deb10u2+rpt1) but 1:8.4p1-5+b1 is installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

Looking at the policy for libc6:

pi@pihole:~ $ apt policy libc6
libc6:
  Installed: 2.31-13+rpi1+deb11u2
  Candidate: 2.31-13+rpt2+rpi1+deb11u2
  Version table:
     2.31-13+rpt2+rpi1+deb11u2 500
        500 http://archive.raspberrypi.org/debian bullseye/main armhf Packages
 *** 2.31-13+rpi1+deb11u2 500
        500 http://raspbian.raspberrypi.org/raspbian bullseye/main armhf Packages
        100 /var/lib/dpkg/status

And same for libc-bin:

pi@pihole:~ $ apt policy libc-bin
libc-bin:
  Installed: 2.28-10+rpt2+rpi1
  Candidate: 2.31-13+rpt2+rpi1+deb11u2
  Version table:
     2.31-13+rpt2+rpi1+deb11u2 500
        500 http://archive.raspberrypi.org/debian bullseye/main armhf Packages
     2.31-13+rpi1+deb11u2 500
        500 http://raspbian.raspberrypi.org/raspbian bullseye/main armhf Packages
 *** 2.28-10+rpt2+rpi1 100
        100 /var/lib/dpkg/status

Current /etc/apt/sources.list && /etc/apt/sources.list.d/raspi.list:

pi@pihole:~ $ cat /etc/apt/sources.list
deb http://raspbian.raspberrypi.org/raspbian/ bullseye main contrib non-free rpi

---

pi@pihole:~ $ cat /etc/apt/sources.list.d/raspi.list
deb http://archive.raspberrypi.org/debian/ bullseye main
3
  • Were you doing a manual upgrade? Do you have a backup of your buster system?
    – Seamus
    Jan 6 at 9:34
  • @Seamus nay ;( - but the system is mostly working just apt is borked Jan 6 at 23:12
  • Backups are so convenient with image-utils... you have officially run out of excuses :)
    – Seamus
    Jan 7 at 0:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.