1

I am a user of obs, Open Broadcaster Software. I am using raspbian bullseye 32 bits OS. I have installed OBS with this command:

sudo apt-get install obs-studio && sudo apt-get install obs-build && sudo apt-get install obs-plugins

But when I launch OBS, I see the following:

pi@raspberrypi:~/obs-studio $ obs
Attempted path: share/obs/obs-studio/locale/en-US.ini
Attempted path: /usr/share/obs/obs-studio/locale/en-US.ini
Attempted path: share/obs/obs-studio/locale.ini
Attempted path: /usr/share/obs/obs-studio/locale.ini
Attempted path: share/obs/obs-studio/locale/fr-FR.ini
Attempted path: /usr/share/obs/obs-studio/locale/fr-FR.ini
info: Using preferred locale 'fr-FR'
Attempted path: share/obs/obs-studio/themes/Dark.qss
Attempted path: /usr/share/obs/obs-studio/themes/Dark.qss
info: Physical Cores: 4, Logical Cores: 4
info: Physical Memory: 3838MB Total, 1793MB Free
info: Kernel Version: Linux 5.10.63-v7l+
info: Distribution: "Raspbian GNU/Linux" "11"
info: Session Type: x11
info: Window System: X11.0, Vendor: The X.Org Foundation, Version: 1.20.11
info: Portable mode: false
Attempted path: share/obs/obs-studio/themes/Dark/no_sources.svg
Attempted path: /usr/share/obs/obs-studio/themes/Dark/no_sources.svg
QMetaObject::connectSlotsByName: No matching signal for on_advAudioProps_clicked()
QMetaObject::connectSlotsByName: No matching signal for on_advAudioProps_destroyed()
QMetaObject::connectSlotsByName: No matching signal for on_actionGridMode_triggered()
QMetaObject::connectSlotsByName: No matching signal for on_program_customContextMenuRequested(QPoint)
QMetaObject::connectSlotsByName: No matching signal for on_transitionRemove_clicked()
info: OBS 26.1.2+dfsg1-2 (linux)
info: ---------------------------------
info: ---------------------------------
info: audio settings reset:
    samples per sec: 48000
    speakers:        2
info: ---------------------------------
info: Initializing OpenGL...
Erreur de segmentation

I do not understand what these Attempted path messages mean - is there something wrong with the obs ports? Please help me!

2
  • No idea, but perhaps it's only working correctly on 64-bit systems? Which Pi are you using - perhaps it requires a Pi 4.
    – 0__
    Jan 7 at 14:38
  • I have a rpi 4 with a 64 bits processor and 4 GB ram Jan 7 at 17:11

2 Answers 2

0

You should try installing it through Pi-apps

To do this run (if you dont have Pi-Apps):

wget -qO- https://raw.githubusercontent.com/Botspot/pi-apps/master/install | bash

Then open Pi-Apps and install it through the UI

How to install obs in Pi-Apps

1
  • I have pi-apps but obs from pi-apps doesn't work Jan 9 at 16:33
0

Unfortunately, the pi-apps version of obs doesn't work on Raspberrian Bullseye. You need to downgrade Raspberrian to the previous version.

1
  • Yes but... my data! I don't want to erase my data and i don't have an other mass storage Jan 12 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.