0

From a: Raspberry Pi 4 Model B Rev 1.4

After installing tightvncserver, things have changed. I've tried uninstalling, but I'm not sure it worked correctly?

sudo apt-get install tightvncserver

Before:

  1. Boot the pi
  2. Land in the standard GUI, already logged in as default user. :)

After:

  1. Boot the pi
  2. Land in the CLI, requires login.
  3. Log in
  4. Try startx, but now it launches a black Openbox screen?? This is useless

Honestly I just want to remove tightvnc, and go back to what it was before.

There was a new(?) ~/.vnc directory with xstart files in it. I removed them and tried again.. to no avail.

How/where/what does startx normally do? Can I reset it without re-imaging the whole card?

1
  • "How/where/what does startx normally do?" -> It runs the application listed in one of a cascading set of files, see man startx.
    – goldilocks
    Jan 10 at 20:03
0

I doubt anyone can solve your problem.

I suggest you restore from your backup or do a fresh install.

My speculation as to cause; I am assuming you are using Raspberry Pi OS Bullseye (which is incomplete). This uses a new compositing Windows manager mutter, which does not use the X stack and installation of tightvnc (which relies on X) would have attempted to restore it.

There was no need to install VNC as Raspberry Pi OS includes Real VNC. This also relies on X and if you enable it it disables the new manager and enables X. You can only have a single VNC server as all implementations of VNC use a common software stack.

I suggest you might like to try reinstalling realvnc-vnc-server (which will replace tightvnc) and enable VNC from the raspi-config menu. You can also enable login options from this menu. If you want to use mutter disabling VNC should restore it.

0

First off, try sudo apt-get remove --purge tightvncserver, reboot and see if the problem persists.

startx desides what to start using the following config files:

$(HOME)/.xinitrc
/etc/X11/xinit/xinitrc
/etc/X11/xinit/xinitrc.d/*
/usr/lib/X11/xinit/xinitrc

Check these files for changes (modification date corresponding to installation of TightVNC). Then you'll have to figure out how to undo the changes. Backup is your friend here. If TightVNC created a new file in /etc/X11/xinit/xinitrc.d/, simply removing it may be enough.

Note that even if you get startx working as before, there may be other changes to your system after the installation of TightVNC. Landind in the standard GUI, already logged in as default user, requires systemd, lightdm and a bunch of other components to be configured properly. Again, backup is your best friend.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.