0

I installed VeraCrypt GUI on my RPi 4 running Raspian 10 Buster using the package veracrypt-1.25.4-Debian-10-armhf.deb on the VeraCrypt website. After checking the signature and successfully installing, clicking on the VeraCrypt application icon does nothing.

When I attempt to mount an external SSD on the command line:

veracrypt /dev/sda2 /mnt/sda2/

I get:

veracrypt: /usr/lib/arm-linux-gnueabihf/libstdc++.so.6: version `GLIBCXX_3.4.26' not found (required by veracrypt)
veracrypt: /usr/lib/arm-linux-gnueabihf/libwx_gtk3u_core-3.0.so.0: version `WXU_3.0.5' not found (required by veracrypt)

Based on this answer, I tried:

apt-file find libwx_gtk3u_core-3.0.so.0

which returned:

libwxgtk3.0-gtk3-0v5: /usr/lib/arm-linux-gnueabihf/libwx_gtk3u_core-3.0.so.0
libwxgtk3.0-gtk3-0v5: /usr/lib/arm-linux-gnueabihf/libwx_gtk3u_core-3.0.so.0.4.0

apt installing libwxgtk3.0-gtk3-0v5 returns:

libwxgtk3.0-gtk3-0v5 is already the newest version (3.0.4+dfsg-8).
libwxgtk3.0-gtk3-0v5 set to manually installed.

Running apt-file find on the other library returns over a hundred results.

To confirm that I'm on a 32-bit system, I ran uname -a, which told me I'm on armv7l.

How do I show VeraCrypt where the libraries are?

1
  • I experienced these errors when I installed VeraCrypt to an SD card pre-loaded with Raspberry Pi OS on purchase, but did not when I used another SD card imaged with the latest RPi OS. Jan 17 at 3:01
1

This error message is not about missing libraries, it is about the discrepancy between the libraries you have in Raspbian and the libraries VeraCrypt was build against (the ones from Debian). They have different versions, so VeraCrypt refuses to run.

You can build VeraCrypt from sources (or find a binary someone else has built), then it will be able to use the Raspbian libraries.

Alternatively you can install an OS for which there is a VeraCrypt package (Arch linux or Ubuntu), and install VeraCrypt on that system.

Finally, you can try to slap Debian libs on top of Raspbian. In my experience, this can sometimes work out (I was able to install unrar in this way). In other cases, it installs libraries which ruin genuine Raspbian software, resulting in a broken system, so a backup is strongly recommended.

There are ways to install different library versions more carefully, using an isolated environment so that the original OS is not affected. That's how Docker works. Incidentally, if you can get Docker installed and find a VeraCrypt container for Debian-ARM, there's a high chance it will work on Raspbian.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.