2

I have got a new Raspberry Pi, and I am eager to work on it, but I am not able to connect to the network from it.

I connect to the Raspberry Pi using SSH. When I try doing the

apt-get update
apt-get install tightvnc

I get the error

Temporary failure resolving 'mirrordirector.raspbian.org'

It looks like many of them have had this issue. I tried several ways suggested by those who got it working that way.

I checked this link and this link and edited the resolv.conf file. The resolv.conf file was having the line nameserver 10.42.0.1 before I edited it.

I added the lines,

nameserver 8.8.8.8
nameserver 8.8.4.4

I connected to the Raspberry Pi using the IP address 10.42.0.69. I don't think so that should be added to resolv.conf file as well.

I have tried editing the /etc/network/interfaces file as well to set a static IP address, but I reverted it back after I found out that I can also assign a static IP address using this command sudo ifconfig eth0 192.168.x.x netmask 255.255.255.0. I like this one because I didn't have to make the interfaces file dirty.

The /etc/network/interfaces looks like this:

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

So, yes, this is a DHCP from a home router.

OS: Raspbian

I cannot ping 8.8.8.8 or any other external IP address. However, I can ping the IP address to my laptop to which I have connected the Raspberry Pi.

I have tried re-flashing the SD card, but I reached nowhere.

  • I also have this issue. It's very frustrating! – hifkanotiks Feb 9 '14 at 11:26
  • If your resolv.conf automatically has been set to 10.42.0.1 its very likely you have to assign your pi an IP in that same range. So something like 10.42.x.x rather then your 192.168.x.x What was the IP assigned by DHCP? (show by running ifconfig -a after a reboot) – ExploWare Mar 12 '14 at 20:59
0

You need to narrow the problem down a bit. Is it that the pi can't access anything on the internet, or just the mirrors? Is it just the pi which is having these problems or do other computers on your network not see the internet either?

Trying pinging mirrordirector.raspbian.org from the pi and from your PC. If neither can see it, then maybe the mirrordirector is having problems at the moment. Try going to a web page on both machines, does that work? Could it be that your ISP is having problems with its nameserver? Could it be that your network cable has popped out of the router?

If it's just the mirrordirector which is causing problems, then try using a different mirror, see if you can ping any of the ones listed at http://www.raspbian.org/RaspbianMirrors .

0

I switched to Pidora and finally I am able to connect to internet. However, I could not figure out the reason why Raspbian was crying ;P

For those who are still stuck with the Raspbian, try different distributions on the Raspberry pi site. Also, I used a TV connected through HDMI and had to configure the initial setup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.