1

So I have a problem that I have half solved and was hoping someone would know how to solve the rest.

So yesterday I encounted a problem that I asked and partially solved at the link below.

CM4 Uart 0 through 5 not working

The problem now is that in the boot partition of Raspbian for example there are six dtbo files in the overlays folder named uart0 through uart5.dtbo. On my custom Yocto version these overlays are missing and as such the serial ports don't work. I do not want to have to manually copy these over as this will be used on a product we must support for a long time. Thus I need to figure out how to get these overlays included in bitbake which generates yocto.

Am I missing a layer or something or something in the local config?

1

1 Answer 1

0

I had trouble googling for this but ultimately the solution to this is already out there

Adding Layers to Yocto Build

You simply need to update the local.conf file with the following for poky-honister. This is just for uart3 and 5 but if you wanted to add the rest just add another line and change the number.

/HONISTER/ RPI_KERNEL_DEVICETREE_OVERLAYS:append = " overlays/uart3.dtbo" RPI_KERNEL_DEVICETREE_OVERLAYS:append = " overlays/uart5.dtbo"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.