-1

I have some hosts on my network that I want to always have the same IP address therefore I set them up under the static DHCP lease section within the pihole configuration.

I then delete the existing lease that host has, and then restart the host. Upon booting up, the pihole leased out the original IP address and not the statically assigned IP address.

How can I force pihole to give it the IP address I want it to have?

1
  • How are you setting the static IP configuration? More importantly, is your static IP in the Range of IP Addresses to hand out within DHCP Settings of Pihole? It should be if you are reserving the IP address in Pihole's DHCP settings. It should not be if you are setting static IP address in the Pi's /etc/dhcpcd.conf file using the `static ip_address=" option.
    – user68186
    Feb 23 at 21:59

1 Answer 1

0

Delete the existing lease, then on the host on your network make sure you are clearing the lease. For example, on archlinux, I did the command

dhcpcd -k

which releases the IP, then when I run dhcpcd again, it takes the static dhcp lease configured on the pihole.

Worked for me... hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.