8

My URxvt renders text very slowly, about 5 lines per second, and doesn't render fully when resized. Is this normal for Xorg and URxvt? Is this caused by the limited RAM on the RPi or by my configuration? Even Xterm is faster than URxvt, editing text with vi is such a pain.

My ~/.Xdefaults

URxvt*transparent: true
URxvt*fading: 10

URxvt*scrollBar: false
URxvt*scrollBar_right: false

URxvt*foreground: #0000FF
URxvt*background: #000000

Is there any way to improve rendering speed?

  • 1
    Tried increasing the available RAM? – Jivings Aug 1 '12 at 23:29
  • @Jivings I bumped it up to 192 MB and added a 1 GB swap on an external HDD. No visible effect whatsoever. – ArchHaskeller Aug 1 '12 at 23:46
  • How about getting rid of the transparency? That usually takes quite a bit of effort on behalf of the WM. – Jivings Aug 2 '12 at 8:55
  • @Jivings Slight improvement but lags so much when compiling. – ArchHaskeller Aug 2 '12 at 18:54
  • What WM are you using? Are there any other settings that you could get rid of? Have you tried any other terminals with similar capabilities as rxvt? For example; terminator. – Jivings Aug 3 '12 at 7:03
1

I believe the problem is with Awesome WM. It is written mostly in Lua, which runs on the Lua Virtual Machine. Since there is an abstraction away from the hardware, performance must take a slight hit (citation needed).

Even if you are using a distribution that supports Hard Float calculations, the Lua VM doesn't. So this will not improve performance as much as with other Window Managers.

As I've said, you can attempt to improve what you can in Awesome by disabling any extra features such as transparency and by increasing the available RAM to the GPU (forget about swap), but perhaps you might want to look at other WMs. I use Xmonad, which is simple like Awesome and is also tiling, so you might get on well with that. It runs on Haskell I believe, and performance for me has been great.

Sources:

| improve this answer | |
  • I've been coding Haskell(hence my name) for a year now .Still Haskell scares me with side effects and monads .Especially monads, how hard is it to configure Xmonad? – ArchHaskeller Aug 12 '12 at 18:29
  • @Haskeller: Easy enough for me to do it, with absolutely zero Haskell experience. – Jivings Aug 12 '12 at 19:24
  • Wheres the package?Do I need ghc to compile XMonad? – ArchHaskeller Aug 12 '12 at 20:25
  • @Haskeller: What is your distro? – Jivings Aug 12 '12 at 20:39
  • I am using Arch Linux Arm. – ArchHaskeller Aug 12 '12 at 22:35
2

Anything running in Xorg is very slow right now due to the lack of 2D acceleration. Any redraws/re-sizes/etc tend to cause very high CPU usage, slowing everything else down to a crawl.

Turning off transparency will help fair a bit as it will reduce the CPU load that comes from performing the alpha blending.

| improve this answer | |
0

It's the font rendering.

For fast urxvt on pi3, I compiled the 9.22 source, configured with --enable-256-color --disable-xft --disable-transparency.

in src/features.h I removed an ifdef and a space to get #define LINUX_YIELD_HACK 0

Nice and zippy now.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.