0

I have a RPI4 that I was running as a desktop for my kids. It was booting from a USB3 HDD, but stopped at some point. I loaded raspberrian onto an SD card to see if there was a problem with the drive. I got it to load the setup sequence once but while using the desktop strange horizontal lines appeared all over the screen and it froze. Attempts to use the original HDD and SD would occasionally boot to the loading screen but then the same sequence with the horizontal lines would occur. However, more often than not I would get just a blank screen.

I was wondering if it was an issue with the graphics card, so I tried starting without any OS media. It loads the bootloader screen just fine, cycling a message

root HUB port 1 init 
USB MSD timed out after 20 seconds 
Restart # max -1 

# incriments every 20 seconds

When I plug in the USB drive or the sdcard it gives me this message

rsc 32 fat-sectors 3044 c-count 516190 c-size 1 r-dir 2 r-sec 0
read cconfig.txt bytes    1783 hnd 0x000184a7 hash '3dfa17ad58a6ed83'
recover4.elf not found (6)
recovery.elf not found (6)
Read start4.elf bytes 2241440 hnd 0x000139b1 hash (#a hash im' too lazy to type)
Read fixup4.dat bytes    5411 hnd 0x0001846b hash (Another hash I'm going to type)
0x000b03114 0x00000000 0x00000fff
MEM GPU: 76 ARM 948 total: 1024

then a blank screen and nothing.

I tried hooking it directly up to my router and I added the files ssh and ssh.txt to my boot section on the SD card (it was unclear which was the correct name from the things I read) and booted it up and scanned for devices with an open 22 port. Nothing new showed up. Also, neither the ACT light nor the ethernet lights are changing, just staying solid.

When I try my hard drive I get essentially the same results except my ACT light is unlit after the boot screen.

I cannot see any physical defects on the device. Any troubleshooting help would be appreciated.

3
  • not sure what "raspberrian" is, you'll want raspberry pi OS - use Raspberry Pi Imager to flash the software - personally I'd recommend flashing the "legacy" Raspberry Pi OS (Buster) - since the Raspberry Pi Foundation released the latest version (Bullseye) without testing it
    – Bravo
    Jan 22, 2022 at 0:23
  • Ha, raspberrian is Raspbian, ie debian for rpi or raspberry pi os. I did try an older OS release with no success already. Pretty sure there's something in the hardware that's broken that's executed downstream of the boot loader.
    – jeffpkamp
    Jan 23, 2022 at 1:14
  • raspbian is not raspberrian, one used to exist, the other is made up - and I believe any version of Raspberry Pi Foundations linux that was called Raspbian is not compatible with Raspberry PI 4 - so, you want Raspberry Pi OS for sure (buster or bullseye)
    – Bravo
    Jan 23, 2022 at 1:17

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.