0

I live in a care home due to illness. I use their wifi for internet access, but for my devices I have a wifi bridge and all my devices connect to its local network. (Before I did this, different devices connected to different networks because the home appears to have several routers with the same SSID?) Now I have all the devices on the same wifi network, I can communicate between all of them if I know the IP address.

However, I have an Octoprint server on a machine with hostname "octopi". If I start it up sometimes I can access it from my laptop (running Linux Mint) as "octopi.local", but after a while it fails to resolve it as "octopi.local" and if I want to access it I have to use the IP address that the DHCP has assigned it. If the IP changes, it appears to work on the octopi.local again for a while after which it stops.

This is very frustrating. I looked into the syslog and the output of dmesg and there appears to be nothing relevant when doing the lookup. I can't find a logfile for mDNS to see if there are any messages saying why its not working. Is there some setting to increase the time it waits?

I've tried using avahi-browse from my laptop to sniff out IP addresses but the machine does not show up on that.

My final resolution might have to be to assign fixed IP addresses to octopi and the other devices I have in a range I hope DCHP never gets to.

1 Answer 1

2

The mDNS protocol is a zero-configuration service, but not the only implementation and AFAIK is not normally used by Linux.
Raspberry Pi OS normally uses avahi-daemon and you can query with
systemctl status avahi-daemon

Not that you need to know the above to use the name location service, but I don't know of any log files.

I use .local extensively on my network, but unfortunately it sometimes just goes to sleep, and while I have tried various techniques to wake it up often the only resort is to restart routers and/or devices.

You could try sudo systemctl restart avahi-daemon to see if that helps.

sudo nmap -sn 10.1.2.0/24 should show active devices on your network (replace 10.1.2.0 with your network).

I don't know what networking system octopi uses, but if dhcpcd like Raspberry Pi OS it is simple to request a known address from your DHCP server.
I normally use reserved addresses for fixed services like printers etc. so I can access them if zero-conf fails.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.